Skip NavigationDesign Science: How Science Communicates
Products Solutions Store Support Reference Company View Cart
 
 
TechNote #108: Last modified: 01/20/05

Resolving Issues Using the MathType 5 Commands for Microsoft Word for Macintosh


The information in this document applies to:

MathType 5.x (Mac)
 

Microsoft Word 2004 (Mac)
Microsoft Word X (Mac)
Microsoft Word 2001 (Mac)
Microsoft Word 98 (Mac)


Issue

Users may experience one or more of the following problems getting MathType 5 to work correctly with Microsoft Word for Macintosh: 

  • The MathType toolbar and menu may be missing
  • Error messages when starting Microsoft Word
  • Error messages when inserting or editing MathType equations
  • Crashes or freezes when using MathType within Word
  • We have a number of other notices that address specific problems that you may experience when using MathType with Microsoft Word. Before following the steps outlined in this TechNote, please consider if one of the notices below addresses your problem specifically:

    107. “Compile Error in Hidden Module: MTLib" message in Microsoft Office X after installing MathType

    74. Equations Are Displayed as Empty or Shaded Boxes in Microsoft Word 

    73. Equations Are Displayed as { EMBED.Equation } in Microsoft Word

    64. "The Disk is Full or Too Many Files Are Open" Error Message in Microsoft Word


    Reason

    The MathType Commands for Word rely on two Microsoft Office components, Visual Basic for Applications (VBA) and Object Linking and Embedding (OLE), to function correctly. If these are not working properly, you may experience the above problems when you try to use the features provided by the MathType Commands for Word.


    Solution

    We have a basic regimen of procedures that reliably corrects problems using the MathType 5 Commands for Microsoft Word by eliminating problems with VBA and OLE. This is done according to the version of Microsoft Office and the version of the Macintosh OS that you are using. Refer to the sections appropriate to the problem and your configuration:

    1. MathType toolbar and menu missing

    2. Error messages when launching Microsoft Word or inserting/editing MathType equations

    Office X Users: MathType 5 requires Microsoft Office X to be at version 10.1.5 (and this updates Word to 10.1.4). Apply this Office update if you have not already, then re-install MathType and try using Word and MathType again: http://www.microsoft.com/mac/downloads.aspx.


    MathType toolbar and menu missing

    If MathType's toolbar and/or menu is missing in Word even after installing MathType, perform the following steps:

    1. Quit Word and all other Office applications.
    2. Locate your Word Startup folder. The default location of the Startup folder is,

      <office folder [version]>:Office:Startup:Word (or custom location set per-user)

    3. Open Word's Startup folder.
    4. Verify the presence of the MathType Commands.dot file. If it is missing, copy it from Applications:MathType 5:Office Support to this folder.
    5. Launch Word.
    6. If the MathType toolbar and/or menu is still missing, choose Tools>Templates and Add-ins.
    7. Enable 'MathType Commands' by checking the box to the left of it. Click OK.
    8. The MathType toolbar and menu should now appear. If not, continue with the steps in the next sections.

    Error messages when launching Microsoft Word or inserting or editing MathType equations

    To resolve any problems in Microsoft Office, follow the steps below to rebuild your desktop (OS 9 only), reset VBA,  force Microsoft Office to create a fresh copy of the OLE registry, delete Word's Normal template and possibly re-install both Office and MathType. Please contact Technical Support if the following steps do not address your problems.

    Office 98 and 2001 Users Only:

    Apple recommends rebuilding your desktop once a month. Symptoms of a desktop that needs to be rebuilt are icons that revert back to generic icons, or which do not do anything when they are double-clicked. Rebuilding your desktop will solve many problems and is always a first good line of defense if you are having any problem with your Mac and have not rebuilt your Desktop recently.

    1. Restart your Mac and hold down the Command and Option keys until you get a dialogue asking you if you want to rebuild your desktop.
    2. Click "Yes".
    3. Your desktop will rebuild itself.
    4. Continue with the steps below.

    All Office Users:

    The following steps will reset VBA.

    1. Launch Word. If you receive errors or Word will not start, skip to step 6.
    2. In Word, choose Tools>Macro>Visual Basic Editor. The Visual Basic Editor will open.
    3. Choose Run>Reset. Nothing will appear to happen, but VBA has been reset.
    4. Choose File>Close and Return to Microsoft Word.
    5. Quit Word and skip to step 15.
       
    6. If Word did not start properly, locate your Word Startup folder. The default location of the Startup folder is,

      <office folder [version]>:Office:Startup:Word (or custom location set per-user)

    7. Open Word's Startup folder.
    8. Drag MathType Commands.dot to the desktop.
    9. Launch Word.
    10. In Word, choose Tools>Macro>Visual Basic Editor. The Visual Basic Editor will open.
    11. Choose Run>Reset. Nothing will appear to happen, but VBA has been reset.
    12. Choose File>Close and Return to Microsoft Word.
    13. Quit Word.
    14. Place MathType Commands.dot back in your Word Startup folder.

    Deleting the following files will force Microsoft Word to create a fresh OLE registry.

    1. Office 98 and 2001 Users: From the System:Preferences folder, delete:

      Embedding Preferences
      PPC Registration Database
      Registration Database (if exists)
      VBA Preferences
      Office Registration Cache
      Microsoft/Office Registration Cache 2001 (Office 2001 only)

      Office X Users: From the Users:<user>:Library:Preferences:Microsoft folder, delete:

    Carbon Registration Database
    Office Registration Cache X

    Office 2004 Users: From the Users:<user>:Library:Preferences:Microsoft folder, delete:

    OLE Registration Database 11
    Office Registration Cache 11

    1. Launch Word again. Word will take longer than usual to load, as the deleted files are recreated by a "First Run".
    2. After Word has finished launching, quit it.

    The Normal Template

    Your Word Normal template contains any macros, styles, or menu and toolbar customizations that you have defined. If you rename or delete it, Microsoft Word will create a fresh one and Microsoft Word will be reset to its defaults. Unless you have defined styles or autotext entries, written or recorded macros, or made toolbar customizations that you want to save, you should delete the Normal template. You will need to redo any menu customizations. If you prefer to save customizations that you have made, rename your Normal template to Normal.bak and use the Organizer to transfer styles, autotext, macros, and custom toolbars to your new Normal template. Word's help files explain how to use the Organizer.

    1. Quit Microsoft Word and open the following folder:

      <office folder [version]>:Templates

    2. Inside, you should find a file called Normal that has a Microsoft Word document icon.
    3. Delete it or rename it Old Normal.
    4. Launch Microsoft Word. Word will take a little longer than normal to start up but will automatically create a new Normal template in your Templates folder.

    After doing all of the above, you should be able to use the MathType Commands for Microsoft Word without difficulty. If none of the above steps help to allow Word and MathType to work together, you will need to remove and re-install Office, then MathType. (As noted above, update to 10.1.5 if using Office X.)

    To reinstall MathType, you can either use your MathType CD-ROM (if you had MathType shipped to you) or download a copy of the MathType 5 installer from our download page.


    Helpful Links
     

    Updates for Microsoft Office for Macintosh are available at http://www.microsoft.com/mac/download/default.asp.

    Instructions for removing Office X and 2004 from your system can be found in this Microsoft Knowledgebase Article.

    Instructions for troubleshooting Office X programs can be found in this Microsoft Knowledgebase Article.


    Top of page

    TechNotes Home   |   TechNote Wizard   |   Contact us

    Copyright © 1996-2018 Design Science. All rights reserved.
    Privacy statement
    Follow MathType: