Skip NavigationDesign Science: How Science Communicates
Products Solutions Store Support Reference Company View Cart
 
 
TechNote #138: Last modified: 11/04/2016

MathType 6.7 commands not available in 64-bit versions of Microsoft Office


The information in this document applies to:
 

  • MathType 6.7 (Windows)
  • Microsoft Office 64-bit (Windows)

Issue:

Microsoft Office comes in both 32 and 64-bit versions. Unlike the 32-bit version of Office, the MathType tab and its commands are unavailable in the 64-bit version of Word and PowerPoint.


Reason:

Microsoft recommends installing 32-bit Office as the default installation on both 32-bit and 64-bit Windows, and only installing the 64-bit version when absolutely necessary. Therefore, MathType 6.7 does not install the MathType tab onto the ribbon in Word and PowerPoint 64-bit.


Solution:

The best solution is to upgrade to MathType 6.9b which brings full functionality to 64-bit Microsoft Office. To upgrade please visit http://www.dessci.com/en/store.

If upgrading is not an option:

Although the 64-bit version of Microsoft Office is not officially supported with MathType 6.7, it still provides limited functionality. Existing equations can be edited by double-clicking them, and new equations can be inserted via Insert > Object. To make this easier, we suggest creating a button in the Quick Access Toolbar to open MathType.

This is a simple two-part process. Step one is recording a macro, and step two is adding your recorded macro to the Quick Access Toolbar.

  1. Recording the macro:
    1. Open Word and click on the View tab.
    2. In the Macros group, click on the drop-down arrow beneath  Macro and select Record Macro.

    1. In the resulting dialog name your macro MathType and choose All Documents (Normal.dotm), under Store macro in:

    1. Click OK to begin recording.
    2. Click the Insert tab in Word's Ribbon.
    3. In the Text group, click on the drop-down arrow and select Object.

    1. Click on MathType 6.0 Equation and click OK.
    2. This will open MathType.
    3. Click anywhere in the Word document to return to the Word ribbon and then click on the View tab.
    4. In the Macros group, click on the drop-down arrow beneath Macro and click Stop Recording.
    5. The Macro has been recorded.
  1. Adding your recorded macro to Word's Quick Access Toolbar: The Quick Access Toolbar located in the upper-left portion of the Word window, is a customizable toolbar into which you can place buttons for your frequently used commands and of course, macros.

    1. Click on the drop-down arrow and select More Commands...

    1. From the drop-down menu labeled Choose commands from: Select Macros.
    2. Click once on the macro name Normal.NewMacros.MathType.
    3. Click the Add >> button.
    4. Optional: You can click the Modify button to change the display name and apply an icon of your choice.
    5. Click OK.
    6. You now have the macro button for MathType located in the Quick Access Toolbar. Any time you wish to insert an equation at the cursor simply click the button in the Quick Access Toolbar and MathType will open ready for you to begin typing your equation.

    Top of page

    TechNotes Home   |   TechNote Wizard   |   Contact us

Copyright © 1996-2018 Design Science. All rights reserved.
Privacy statement
Follow MathType: