Skip NavigationDesign Science: How Science Communicates
Products Solutions Store Support Reference Company View Cart
TechNote #153: Last modified: 08/14/2017

MathType: Error message: "The linked file is not available"

The information in this document applies to:


  • MathType 6.9 and later (Windows)
  • MathType 6.7 and later (Macintosh)
  • Microsoft Word 2007 and later (Windows)
  • Microsoft Word 2011 (Macintosh)

In this article:

Explanation -- Why does this happen?
Resolving the error


When inserting an equation number or a numbered equation in Word, you see this pop-up message (from Word 2013; other versions of Word will be similar, though text may vary):

Picture of error: The linked file is not available.

You may have to click OK multiple times before the dialogs quit appearing.


When you insert an equation number or a numbered equation, MathType will normally update all the equation numbers, references, and links in the document. It may seem like the error message is caused by MathType, but this is not the case. It is because a "linked object", typically a chart, is missing. Since Word cannot find the linked object, it's letting you know the object's information cannot be updated.

Explanation -- Why does this happen?

This typically happens either when working on a document you received from someone else, or when working on your own document on a different computer than on which you originally created it. Either way, there's an included attachment that is now missing.

Linking or embedding objects

Word has two ways that it can handle "objects" that aren't part of the document's text. An object can be a picture, an Excel chart, or any number of other things you choose to add to a document. Even MathType equations are objects.

  • Embedded objects. One way Word can include objects in a document is to embed the objects. Embedded objects become part of the Word document, so if you were to send the document to someone else or to edit it yourself on a different computer, all you need is the document. MathType equations are by default embedded objects, but if you choose, you can link them instead.
  • Linked objects. The other way Word manages objects is to link the objects. A linked object is a separate file, saved either on your computer, or on removable storage or a network drive. Word includes only the link to the object rather than the object itself, so if you send the document to someone else or edit it on another computer, you must include all the files for all the linked objects.

Note that you cannot tell simply by looking at a document in Word whether its objects are linked or embedded -- or some of both. The visual appearance is the same.

The choice of whether to embed or link an object is always up to the author. The default method is to embed the objects. Since this is the default and there are more steps to link an object than to embed one, many people do not know about linking.

  • Advantages of embedding are that it's easier, and since everything is contained within one file, the one file is all you need for editing it on a different computer.
  • Advantages of linking objects are that it results in a smaller Word file, which we believe also makes for a more stable Word file. Also, linking allows an object to be created once and used multiple times either in your own document or those of colleagues. When a linked object is edited, once the links are updated in documents containing the linked object, changes will be reflected in all documents containing the object.
  • When dealing with objects, one thing to remember is that since Word did not create the objects (linked or embedded), if you need to edit these objects you'll need the software they were created with -- MathType for example. If all you need to do is read and print a document with objects, or if you need to edit its text, all you need is Word.

Resolving the error

If you no longer have the linked files for the missing objects, your only option is to re-create the missing objects (or ask the document author to send you the files). Resolving this error is simple if you have the linked files. It's a matter of correcting the link and telling Word where to find the linked file.

Finding the links

The first step is to find the list of links so you can provide the correct one to Word and update the document. The text of the error dialog gives you some clues, but unfortunately the text isn't perfect. It says (in Word 2013), "To edit the link, click the File tab, and then under Related Documents, click Edit Links to Files." In plain English, this is what it means:

  • Word 2010 & later: Click the File tab on Word's ribbon. In the list on the left, Info will be pre-selected. There will be 2 columns of information on the right. At the bottom of the right column will be something that looks like this:
    screen shot showing the "Edit Links to Files" link
    Click Edit Links to Files.
  • Word 2007: Click the Office button (in the upper left of the screen), and on the left, hover the mouse pointer over Prepare. In the menu that appears, choose Edit Links to Files, which will be the last item shown.
  • Word 2011: In Word's Edit menu, choose Links.

Correcting the links

After following the previous step, the Links dialog will appear (this is from Word 2013 on Windows 8.1, but will appear similarly in all other configurations):

Word's "Links" dialog

Notice the 5 lines that have dashes in the Item column. These are the objects that Word cannot find, and for which we need to provide a correct link. In this particular document, we would have had to press OK five times to dismiss the "missing link" dialogs shown at the beginning of this article. There will always be one error dialog for each missing link.

To correct a link, select it by clicking it once. Click the Change Source button on the right, and navigate to the location on your computer or network drive where the source file is located. Once you find it, select it and click Open. When you've corrected all the links, click Update Now, and wait for Word to make the corrections, then click OK. For each one you correct and update, the dashes will be replaced with OK in the Item column:

Word's "Links" dialog, with corrected links

Now save the document with the corrected links, and you should be able to add MathType numbered equations without getting the "missing link" error.

We hope this has been helpful. As always, please let us know if you have questions about this, or if you have additional techniques that work. We'd love to hear from you.

Top of page

TechNotes Home   |   TechNote Wizard   |   Contact us

Copyright ©1996-2018 Design Science, a Wiris company. All rights reserved.
Privacy statement
Follow MathType: