Skip NavigationDesign Science: How Science Communicates
Products Solutions Store Support Reference Company View Cart
 
 
TechNote #112 Last modified: 02/17/05

Guide for Physically Disabled and Low Vision Users


The information in this document applies to:

MathType 6.x
MathPlayer (Windows)

Microsoft Word (Windows)
Internet Explorer (Windows)
Microsoft Word (Macintosh)
Various other Windows and Macintosh applications


Issue

Many low vision and/or physically disabled users would like to use MathType to enter equations.

To better comply with the "No Child Left Behind" legislation, teachers would like to test their mainstream and disabled students using the same examination material. However, some disabled students are unable to submit handwritten mathematics, are unable to use a mouse, and/or have low vision. Teachers can use MathType and Microsoft Word to prepare examinations for their mainstream students, and then provide an electronic copy of the Microsoft Word document to their physically disabled or low vision students for them to edit electronically using MathType's accessibility features. Other users may wish to use MathType's accessible math entry features in order to cut-and-paste MathType’s MathML output into less accessible products. Some customers also wish to use MathType to speak equations out loud.

In other cases, teachers, content providers, or disabled students require an accessible way to generate accessible mathematical content (MathML) for speech output via MathPlayer, or to meet W3C WCAG guidelines for accessible web content or federal Section 508 guidelines (federal buyers see also our Section 508 Voluntary Product Accessibility Template). This can be done using MathType’s MathPage feature in combination with our MathPlayer product.

Although MathType is not designed for use by someone who has no vision, it has special accessibility features that make it easier to use by someone with low vision, or someone who requires an extra large on-screen target for a special input device, such as an eye-tracker.

Mathematical equations input in MathType can then be transferred to Microsoft Word, cut and pasted into other vendors' applications using MathML, or spoken aloud using MathType's MathPage feature in conjunction with Design Science’s MathPlayer software for Windows and optional screen reading software.

Please see Math Accessibility Solutions to learn more about accessible mathematics.

Reason

Many in the accessibility community are unaware of these popular MathType accessibility features. This document is designed to familiarize customers with the accessibility features included in MathType.


Solution

This notice addresses the following topics:

1. Making MathType’s Toolbars Extra-Large for Accessibility

2. Creating Customized Keyboard Shortcuts

3. Exporting Equations into Less Accessible Software Products

4. Speaking Math in MathPlayer (Windows Only)


Making MathType’s Toolbars Extra-Large for Accessibility

MathType contains optional extra large toolbars for easy accessibility. These toolbars provide an extra-large target for someone using an assistive input device, such as an eye movement tracker, or to make reading easier for someone with low vision.

Controls in the Workspace Preferences dialog

 

To make MathType’s Toolbars Extra-Large for Accessibility:

  1. In MathType, choose Preferences>Workspace Preferences… to open the Workspace Preferences Dialog.
  2. In the Workspace Preferences dialog, chose the Large setting for Toolbar size.
  3. Optionally, in the Workspace Preferences dialog, chose the Large settings for the Insertion Point Thickness and/or the Empty Slot Thickness settings, if desired.
  4. Click the OK button to close the Workspace Preferences dialog and return to MathType. MathType will remember your changed preferences in future sessions.

Creating Customized Keyboard Shortcuts

All of MathType's features can be accessed via keyboard shortcuts, which are completely customizable.

To create a customized keyboard shortcut for a MathType feature:

  1. MathType will allow you to create customized shortcuts for commands as well as for symbols and templates. Optionally, if you wish to create a customized shortcut for a symbol or template, first use that symbol or template in the MathType equation editing workspace using the normal MathType equation editing commands. This will cause MathType to add those symbols or templates to its list of recently used symbols or templates. This will make it easier to find and select these symbols or templates in the Customize Keyboard dialog.
  2. In MathType, choose Preferences>Customize Keyboard… to open the Customize Keyboard Dialog.
  3. In the Customize Keyboard dialog:
    1. Click the "+" symbols in the "Command:" section to expand the appropriate category of the command or symbol that you which to create a customized keyboard shortcut for. Menu commands are found in the appropriate section for the menu in question, while symbols and templates can be found in those sections. If you recently used the symbol or template (see optional Step 1 above), it will also appear in the list of "Recently Used Symbols and Templates," making it easier to find. Continue to click the "+" symbols to expand appropriate categories and subcategories of commands until the desired command or symbol appears. Once the desired command or symbol appears in the list, select it to begin creating a keyboard shortcut.
    2. Optionally, if an existing keyboard shortcut is present for the command or symbol, click the "Remove" button to remove the existing keyboard shortcut. Commands and symbols may have multiple short-cuts. The status bar message that appears when you place the mouse pointer over an item while editing in MathType will always show the factory default shortcut, unless it has been removed as described in this step. If the factory default shortcut has been removed, a new short-cut, if any, will be displayed in the status bar message.
    3. Enter the desired new shortcut for the command or symbol in the "Enter new shortcut key(s):" input field.
    4. Click the "Assign" Button.
  4. Repeat Step 3 to assign any additional keyboard shortcuts, as desired.
  5. Click the "Close" button in the Customize Keyboard dialog to save your new keyboard shortcut(s) and return to MathType.

For more information on keyboard shortcuts, please refer to the MathType User Manual.


Exporting Equations into Less-Accessible Software Products

MathType's accessibility features can be used to enter mathematical equations into less accessible software products. For this feature to work, the software products must support input in the MathML W3C standard.

  1. Configure MathType for accessible equation entry as described elsewhere in this TechNote.
  2. In MathType, choose Preferences>Translators… to open the Translators Dialog.
  3. In the Translators dialog, chose the "Transform to other language (text)" radio button.
  4. In the Translators dialog, chose "MathML 2.0 (no namespace)" from the "Translator" list.
  5. Click Close to return to MathType.
  6. Enter an equation in MathType.
  7. Copy the entered equation to the clipboard and then paste it into the less accessible software product. If the less accessible software supports MathML 2.0 importation via cut-and-paste, equations should appear correctly in other vendor's software. (Note that for maximum compatibility, there are additional options for MathML export in the "Translator" list in step 4, as well as options for export in various TeX-based formats.)

Speaking Math Using MathPlayer (Windows Only)

  1. Blind users: have a sighted colleague complete Steps 2 through 9 for you the first time around. Then continue reading at Step 10 below.
  2. Make sure the MathPlayer product is installed. MathPlayer is available as a free download from the Design Science web site.
  3. Make sure Microsoft Internet Explorer is configured as your default browser. Instructions for making Internet Explorer the default browser may vary between versions; the instructions here are for Internet Explorer for Windows version 6.0. From Internet Explorer, choose Tools>Internet Options… to open the Internet Options Dialog. Choose the  Programs tab, and check the "Internet Explorer should check to see whether it is the default browser" box. Click "OK" to return to Internet Explorer. Chose File>Close to exit Internet Explorer. Restart Internet Explorer. If a dialog appears asking to make Internet Explorer the Default Browser, click Yes.
  4. Windows XP SP2 users should configure Internet Explorer to allow active content to run from local files on their computer. In Internet Explorer, choose Tools>Internet Options... to open the Internet Options... dialog. Click the Advanced tab near the top right of the dialog. Use the scroll bar in the dialog to scroll down to the Security section near the bottom. Make sure the "Allow active content to run on files on My Computer" option in the dialog is checked. Click "OK" in the dialog to return to Internet Explorer. Chose File>Close to exit Internet Explorer.
  5. Open Microsoft Word and use Word and MathType to create mathematical content to be spoken in MathPlayer.
  6. In Microsoft Word, choose File>Save to open the Save As…dialog. Enter an appropriate filename in "file name" box, then click "Save" to save the file and return to Microsoft Word.
  7. In Microsoft Word, choose MathType>MathPage… to open the MathPage dialog.
  8. In the MathPage dialog:
    1. Optionally enter a Title for the page.
    2. Check the "Display in Default Brower" box.
    3. Choose the "MathML using:" option.
    4. Choose the "MathPlayer (IE behavior)" from the list below the "MathML using" option.
    5. Choose "Internet Explorer 5 or newer (Windows) - faster download" as the Target Browser.
  9. Click OK in the MathPage dialog to generate the page and return to Microsoft Word. An information window will appear in Word as the page is generated. After a few moments, an Internet Explorer window should open. Windows XP SP2 users who chose not to complete Step 4 above may see a warning message in Internet Explorer about an "Information Bar" or "Blocked Content"; if so, first clear any "Information Bar" Dialog  that appears by clicking "OK", then click the "To help protect your security…" bar and select "Allow Blocked Content." To speak the math on the page, have your optional screen reader software read the page. If you do not have optional screen reader software installed, right-click the equation and select "Speak Expression" from the drop-down menu.
  10. Blind users: Once your sighted colleague has configured MathType as described in Steps 2 through 9, MathType will remember your MathPage settings in future sessions. If screen reading software is installed, you should be able to use MathType to speak equations created by others in Word files by using the following keyboard short-cuts from inside Word: Control-s to ensure the document is saved, Alt-m followed by 'x' to bring up the MathPage dialog box, and the Enter key to generate the web page and then bring up Internet Explorer to speak the accessible math in MathPlayer.

 


Top of page

TechNotes Home   |   TechNote Wizard   |   Contact us

Copyright © 1996-2017 Design Science. All rights reserved.
Privacy statement
Follow MathType: