Skip NavigationDesign Science: How Science Communicates
Products Solutions Store Support Reference Company View Cart
 
 
TechNote #25: Last modified: 10/20/99
Last reviewed: 10/20/99

Using MathType 3.0x with Microsoft Word 6.0 for Windows


The information in this document applies to:

MathType 3.0 (Win)

Microsoft Word 6.0 (Win)

MathType 3.0x (3.0a-3.0c) is generally compatible with MS Word 6.0 for Windows with the following exceptions:

  1. Its OLE (Object Linking and Embedding) registration for Equation Editor causes MathType equations to be converted to Equation Editor objects which, when double-clicked, run Equation Editor rather than MathType.
  2. The WordBasic macros we supply will not work as the WordBasic macro language was changed with the release of MS Word 6.0 for Windows.

We have a upgrade available that fixes these problems and we highly recommend you order it.


MS Word 6.0 for Windows and Microsoft Equation 2.0

MS Word 6.0 for Windows comes with version 2.0 of Microsoft Equation, a new version of the junior version of MathType we license to Microsoft. Unfortunately, if you install Microsoft Equation 2.0 with MS Word 6.0, your MathType equations will be automatically converted into Microsoft Equation 2.0 equations. This is undesirable if you want to continue using MathType to create and edit equations.

We recommend you do not install Microsoft Equation 2.0 as part of your MS Word 6.0 installation. Microsoft Equation 2.0 is optionally installed via a custom installation, but if the "Typical” or “Laptop (minimum)” install are selected. If you have installed MS Word 6.0 already and you are unsure whether you have installed Microsoft Equation 2.0, choose Object from the Insert menu of Word. If “Microsoft Equation 2.0” shows up, it has been installed.

If you did not install Microsoft Equation 2.0, MathType 3.0(a-c) will work just fine except the WordBasic macros we supply will not work.

If you did install Microsoft Equation 2.0, as part of your MS Word 6.0 installation, you will have to get uninstall it and reinstall MathType. Before you do this, however, you must repair the damage done to your documents containing equations that were opened or created with Microsoft Word 6.0. If opened a document after installing MathType, all its equations will have been converted to Microsoft Equation 2.0 objects.


Converting Microsoft Equation 2.0 equations back to MathType equations

First, you must adjust the OLE registration on your system to allow Microsoft Equation 2.0 and MathType to coexist. To do this:

  1. Choose Run from your Windows Start menu.
  2. In the Command Line box type: "REGEDIT /V". 
  3. Click OK to run the Registration Info Editor
  4. Choose Search/Find Key.
  5. In the Find Key dialog type in the following:

\CLSID\{0003000B-0000-0000-C000-000000000046}\AutoConvertTo

  1. Click Find Next.
  2. Choose Edit/Delete Key
  3. When asked to confirm the deletion of the key, click OK.
  4. Choose Save Changes from the File menu.
  5. Choose Exit from the File menu.

Next you must convert each Microsoft Equation 2.0 equation into a MathType equation:

  1. Launch MathType.
  2. Double-click on a Microsoft Equation 2.0 equation in your Word document
  3. Select the entire equation.
  4. Copy the equation from the Microsoft Equation 2.0 window and paste it in the MathType window.
  5. Copy the equation from the MathType window and paste it back into your Word document.
  6. Repeat steps 2-5 for each equation in each document

Now you are ready to remove Microsoft Equation 2.0. To do so:

  1. Launch the Word setup application by:
  1. Double-click on the Word Setup icon, or
  2. Put your MS Word 6.0 Disk 1 in your floppy drive, choose Run from the Windows Start menu and type A:SETUP (or B:SETUP) and click OK.
  1. Click Add/Remove.
  2. Double-click on Graph, Equation, WordArt.
  3. Highlight the Equation Editor item in the list box and click its check box to uncheck it
  4. Click OK then Continue.
  5. When asked to confirm the removal of one component click Yes.
  6. When asked to remove Equation Editor which is a shared component, click Remove.

Finally, you must re-install the MathType application in order for MathType’s OLE registration to be re-established:

  1. Insert your MathType floppy disk and double-click on the MathType Setup icon from your MathType Windows group.
  2. Click on Custom Install, select the “MathType application” item and click OK .

MS Word 6.0 problems with SHARE and Windows 3.1x

As of the date of this release (September 1994), under some circumstances MS Word 6.0 may experience problems saving files. The problems are related to the number of file locks allocated by SHARE, a DOS program that controls file sharing locking. Word's problems can be avoided by allocating a larger number of locks; 100 seems to work with small documents, but the rule of thumb seems to be about 4 locks per equation in your document, (so a document with 400 equations needs a setting of about 1600 locks.) You can increase the number of locks by finding where SHARE is being initialized (either CONFIG.SYS or AUTOEXEC.BAT) and changing (or adding) the /L parameter. For example:

SHARE /L:100/F:1000

The /F: parameter needs to be changed in proportion to the /L: parameter, so every time /L: doubles, /F: should also.

MS Word 6.0a for Windows solves this problem by installing a program called vshare.386 into your System.ini file, eliminating the need to use SHARE at all. If you have 6.0a, you will want to remove SHARE from your AUTOEXEC.BAT to avoid conflicts.

For more information consult your DOS manual, or contact Microsoft's Technical Support.


MathType’s WordBasic Macros

Do not install the WordBasic macros that we provide with MathType versions prior to 3.0c (WWMACROS.DOC) into WW6 as they will not install properly.


Top of page

TechNotes Home   |   TechNote Wizard   |   Contact us

Copyright © 1996-2018 Design Science. All rights reserved.
Privacy statement
Follow MathType: