Skip NavigationDesign Science: How Science Communicates
Products Solutions Store Support Reference Company View Cart
 
 
TechNote #31: Last modified: 10/20/99
Last reviewed: 10/20/99

Using MathType 3.x with WordPerfect for Macintosh 3.1


The information in this document applies to:

MathType 3.x (Mac)

WordPerfect 3.1 (Mac)

Pasting MathType equations into WordPerfect

To paste equations into a WordPerfect document, use the following procedure:

  1. Launch MathType and create an equation.
  2. Choose Select All from the Edit menu to highlight the equation.
  3. Choose Copy or Cut from the Edit menu.
  4. Switch to WordPerfect and place the insertion point where you would like to insert the equation.
  5. Select Paste from the Edit menu of WordPerfect.

The equation is now placed at the insertion point, in-line with any surrounding text.


Editing equations with EGO

WordPerfect’s support for Edit Graphic Object (EGO) allows equations copied into WordPerfect documents to be edited via the following procedure:

  1. Double-click on the equation within the WordPerfect document. 
  2. The equation will be opened inMathType.
  3. After editing the equation, click the close box or select Close from the File menu.
  4. When MathType asks if you want to update the equation in your document, click Update.

The equation in your document will reflect your edits.

Note: A problem occurs after an EGO edit of an equation, when subsequent equations are copied and pasted from MathType into WordPerfect. Double-clicking on these equations may result in the program crashing. The workaround is to save the document after each EGO edit, which seems to repair the damage. 


 Importing MathType equation files into WordPerfect

WordPerfect accepts equations saved as both types of EPS files and as PICT files. To import MathType equation files into WordPerfect:

  1. Create an equation within MathType.
  2. Select Save from the File menu. Save the equation in any format.
  3. From within WordPerfect, select Insert File from the File menu.
  4. Select the file you just saved.

Note: Imported PICT files automatically baseline-adjust, but the two EPS file formats do not. See the following section, Aligning EPS Files with the Baseline, for instructions on adjusting them manually.


Aligning EPS files with the baseline

The following procedure will align EPS Files with the baseline:

  1. Make sure that you are using points as your measurement units within WordPerfect. To set the measurement units to points:
  1. Select Preferences from the Edit menu, then select Environment.
  2. Select Points from the Units menu (in the Environment window).
  3. Click on OK.
  1. Load the equation into MathType by selecting Open from MathType’s File menu and then selecting the name of the equation file.
  2. Choose Select All and then Copy from the Edit menu.
  3. Write down the Baseline: number that is displayed in MathType’s status bar.
  4. Click once on the equation from within WordPerfect.
  5. Select Graphic from the Tools menu. Then select Options
  6. Find the Vertical Position section of the Graphic Options dialog box. In the box next to Offset, enter the number that you wrote down in step 4 above.
  7. Click OK.

Copying or moving equations to other parts of your document

Dragging an equation to another part of the document will result in an inability to place the equation in-line with text. However, using Copy (to copy) or Cut (to move) allows equations to be pasted in-line. Equations copied or moved in this manner must be manually baselined. To baseline these equations:

  1. Double-click on the equation in your WordPerfect document to bring it back into MathType.
  2. Choose Select All and then Copy from the Edit menu.
  3. Write down the Baseline: number that is displayed in MathType’s status bar.
  4. Return to WordPerfect by either clicking in the close box or by selecting Close from the File menu. 
  5. When MathType asks if you want to update the equation in your document, click on Don’t Update. Note: It is not a good idea to simply switch back to WordPerfect without closing the equation window, as the EGO equation will remain open in the WordPerfect document.
  6. Follow steps 5 through 8 in the above section, Aligning EPS files with the baseline.

Top of page

TechNotes Home   |   TechNote Wizard   |   Contact us

Copyright ©1996-2018 Design Science, a Wiris company. All rights reserved.
Privacy statement
Follow MathType: