Skip NavigationDesign Science: How Science Communicates
Products Solutions Store Support Reference Company View Cart
TechNote #33: Last modified: 10/20/99
Last reviewed: 10/20/99

Using MathType 3.1 with MacWrite Pro 1.5

The information in this document applies to:

MathType 3.1 (Mac)

MacWrite Pro 1.5

MathType works well with MacWrite Pro using cut and paste, EGO, and imported files. The first page of this document discusses specific issues relating to MathType’s use with MacWrite Pro. If you want more detailed instructions on the standard procedures for inserting and editing equations, see the second page of this document.

Aligning EPS files with the baseline

The best way to bring MathType equations into a MacWrite Pro document is cut and paste. Equations inserted in this manner automatically baseline adjust and can be edited using the EGO protocol. The following instructions are for people who want to bring equations in as imported files.

EPS files without attached PICTs do not automatically baseline adjust. EPS files with attached PICTs and PICT files adjust without any problems. The following procedure will align EPS files without attached PICTs with the baseline:

  1. Make sure that you are using points as your measurement units within MacWrite Pro. To set the measurement units to points:
  1. Select Preferences from the Edit menu, then select Document.
  2. Select Points from the Unit of Measure pull-down.
  3. Click on OK.
  1. Load the equation into MathType by selecting Open from MathType’s File menu an then by double-clicking on the name of the equation file.
  2. Choose Select All and then Copy from the Edit menu.
  3. Write down the Baseline: number that is displayed in MathType’s status bar.
  4. Click once on the equation from within MacWrite Pro.
  5. Select Modify Frame from the Frame menu.
  6. Find the Position section of the Modify Frame dialog box. In the box next to Baseline, enter the opposite of the number that you wrote down in step 4 above (e.g. if the number you wrote down was 14, enter “-14”).
  7. Click OK.

The equation is now aligned properly.

Pasting MathType equations into MacWrite Pro

To paste equations into a MacWrite Pro document, use the following procedure:

  1. Run MathType and create an equation.
  2. Choose Select All from the Edit menu to highlight the equation.
  3. Choose Copy or Cut from the Edit menu.
  4. Switch to MacWrite Pro and place the insertion point where you would like to insert the equation.
  5. Select Paste from the Edit menu.

The equation is now placed at the insertion point and automatically baseline adjusts.

Editing equations with EGO

MacWrite Pro’s support for Edit Graphic Object (EGO) allows equations copied into MacWrite Pro documents to be edited via the following procedure:

  1. Double-click on the equation while holding down the Command key within the MacWrite Pro document. MathType will run and the equation will appear in its window.
  2. After editing the equation in MathType, click in the close box or select Close from the File menu.
  3. When MathType asks if you want to update the equation in your document, click on Update.

The equation in your document will automatically reflect the changes that you made.

Importing MathType equation files into MacWrite Pro

MacWrite Pro accepts equations saved as both types of EPS files and as PICT files. To import MathType equation files into MacWrite Pro:

  1. Create an equation within MathType and then select Save from the File menu. Save the equation in any format.
  2. From within MacWrite Pro, select Insert from the File menu.
  3. Select the file you just saved.

Note: Imported PICT and EPS w/ PICT files automatically baseline adjust, but EPS files without PICTs do not. See the above section, Aligning EPS Files with the Baseline, for instructions on adjusting them manually.

Top of page

TechNotes Home   |   TechNote Wizard   |   Contact us

Copyright ©1996-2018 Design Science, a Wiris company. All rights reserved.
Privacy statement
Follow MathType: