Skip NavigationDesign Science: How Science Communicates
Products Solutions Store Support Reference Company View Cart
 
 
TechNote #48: Last modified: 10/20/99
Last reviewed: 09/14/00

MathType 3.x Macro Localizations for German Versions of Microsoft Word


The information in this document applies to:

MathType 3.1 (Win)
MathType 3.5 (Win)

Microsoft Word 5 (Win)
Microsoft Word 6 (Mac)
Microsoft Word 95 (Win)
Microsoft Word 97 (Win)

Issue

The German version of Microsoft Word does not use "^g" to denote graphic locations so when MathType's Update Equation macro is run, it will not find any of the equation objects and therefore will generate a message that no MathType equations were located.


Solution

Localizing the macro

The UpdateEquation macro will need to be updated so that the "^g" references are changed to "^r", which is the code the German version of Word uses to denote graphic objects. NOTE: Searching for the "^g" will not work. Microsoft's search engine seems to only be able to find command names.

  1. Select Makro from Word's Extras menu; This will display a dialog with all your installed macros associated with the document template that you have loaded.
  2. Scroll through the listing of macros until you find MTUpdateEquations and click on it once to highlight the entry; This will enable the Bearbeiten button located to the right of the list.
  3. Press Bearbeiten; this will load the macro file into a editing window.
  4. Select Suchen... from Word's Bearbeiten menu; This will display a dialog in which to specify a search parameter.
  5. In the field next to Suchen nach:, type "BearbeitenSuchen", without quotes.
  6. Press Weitersuchen until you reach the following line:

BearbeitenSuchen .Suchen = "^g", .Richtung = 0, .GanzesWort = 0, \.GrofKleinschreibung = 0, .Mustervergleich = 0, .Reserviert23 = 0, .Format = 0

  1. Change the "^g" to "^r".
  2. Press Weitersuchen until you reach the following line:

BearbeitenSuchen .Suchen = "^g", .Richtung = 0

  1. Change the "^g" to "^r".
  2. Select SchlieBen from Word's Datei menu.
  3. When prompted to save, press the Ja button.

After you have done this, load your document with the equations that you want to run the UPDATE EQUATIONS macro on in Word and run the macro.


Top of page

TechNotes Home   |   TechNote Wizard   |   Contact us

Copyright © 1996-2018 Design Science. All rights reserved.
Privacy statement
Follow MathType: