Skip NavigationDesign Science: How Science Communicates
Products Solutions Store Support Reference Company View Cart
 
 
TechNote #49: Last modified: 06/25/04
Last reviewed: 06/25/04

Advanced Equation Numbering in Microsoft Word


The information in this document applies to:

MathType 3.1 (Win)
MathType 3.5 (Win)
MathType 3.6 (Mac)
MathType 3.7 (Mac)
MathType 4.0 (Win)

MathType 5.1 (Win)

MathType 5.1 (Mac)

MathType 5.2 (Win)

Microsoft Word 6 (Win & Mac)
Microsoft Word 95 (Win)
Microsoft Word 97 (Win)
Microsoft Word 98 (Mac)
Microsoft Word 2000 (Win)
Microsoft Word 2001 (Mac)
Microsoft Word 2002 (Win)

Microsoft Word X (Mac)

Microsoft Word 2003 (Win)

Microsoft Word 2004 (Mac)

 

Issue

This notice is aimed at those MathType users who wish to extend the power of the MathType equation numbering commands. If you have any questions concerning the WordBasic language in particular, please consult your Microsoft Word user's manual or contact Microsoft.

Please Note: MathType versions 4.0 and later allows you the ability to quickly customize the appearance of equation numbers using macros in Microsoft Word (click here to read more about MathType and its other features).  Thus, the information in this TechNote doesn't mention MathType 4.x and 5.x, although parts of this document are still applicable.


Solution

Getting the most out of your MathType commands for Microsoft Word

Users of MathType 3.1 and earlier should be sure to read the MathType User's Supplement Manual starting with the section entitled "Using the Commands" on page 14 through 23 (Windows) or pages 12 through 21 (Macintosh).  MathType 3.5, 3.6, and 3.7 users should refer to chapter 5 of their manuals in the sections entitled "Using MathType with Microsoft Word". These pages are specifically aimed at Microsoft Word / MathType command users and contain additional information concerning the Microsoft Word menu items that is not listed in this notice.


Viewing Field Codes in Microsoft Word

The equation numbering commands provided by MathType utilize field codes within Microsoft Word. This allows Microsoft Word to maintain its control and performs most of the work for keeping track of sections, numbers and references.

These field codes can be turned off and on from view by doing the following:

  1. Select Options... from Microsoft Word's Tools menu; this will display a 12 tab dialog on one of which will be the word View.
  2. Select the View tab.
  3. Place a check in the box next to Field Code to turn them on for viewing, uncheck the box to turn them off from view.

Once the field codes are turned on, if you have equation objects, sections, and numbers in your document, you will see something like this:

Equations objects:

MathType 3.x : { EMBED Equation }

 

MathType 4.x - 5.x: { EMBED Equation.DSMT4 }

Section increments:

MathType 3.x: { { seq MTSec \h }{ seq MTEqn \r \h } }

 

MathType 4.x - 5.x: {MACROBUTTON MTEditEquationSection2{SEQ MTEqn \r \h \* MERGEFORMAT}{SEQ MTSec \r 1 \h\*MERGEFORMAT}

Equation numbers (will vary slightly depending on your definitions):

In Microsoft Word 2.0, 6.0 and 95 the code will look like:

{ commandbutton MTPlaceRef { seq MTEqn \h }({ seq MTSec \c }.{ seq MTEqn \c })}

In Microsoft Word 97 - 2004, the code is almost the same with \*mergeformat added to each field code segment:

{ macrobutton MTPlaceRef \*mergeformat{ seq MTEqn \h \*mergeformat}({ seq MTSec \c \*mergeformat}.{ seq MTEqn \c \*mergeformat})}


Removing Section Increments

If you have a situation in your document where you have alternating equation numbers like:

w/ section #'s

(1.1)
(1.2)
(2.1)
(2.2)

w/out section #'s

(1)
(2)
(1)
(2)

...it means that the field codes will look something like the following:

In Microsoft Word 2.0, 6.0, and 95:

{ { seq MTSec \h }{ seq MTEqn \r \h } }
{ commandbutton MTPlaceRef { seq MTEqn \h }({ seq MTSec \c }.{ seq MTEqn \c })}
{ commandbutton MTPlaceRef { seq MTEqn \h }({ seq MTSec \c }.{ seq MTEqn \c })}
{ { seq MTSec \h }{ seq MTEqn \r \h } }
{ commandbutton MTPlaceRef { seq MTEqn \h }({ seq MTSec \c }.{ seq MTEqn \c })}
{ commandbutton MTPlaceRef { seq MTEqn \h }({ seq MTSec \c }.{ seq MTEqn \c })}

In Microsoft Word 97 - 2004:

MathType 3.x:

{ { seq MTSec \h }{ seq MTEqn \r \h } }
{ macrobutton MTPlaceRef \*mergeformat{ seq MTEqn \h \*mergeformat}({ seq MTSec \c \*mergeformat}.{ seq MTEqn \c \*mergeformat})}
{ macrobutton MTPlaceRef \*mergeformat{ seq MTEqn \h \*mergeformat}({ seq MTSec \c \*mergeformat}.{ seq MTEqn \c \*mergeformat})}
{ { seq MTSec \h }{ seq MTEqn \r \h } }
{ macrobutton MTPlaceRef \*mergeformat{ seq MTEqn \h \*mergeformat}({ seq MTSec \c \*mergeformat}.{ seq MTEqn \c \*mergeformat})}
{ macrobutton MTPlaceRef \*mergeformat{ seq MTEqn \h \*mergeformat}({ seq MTSec \c \*mergeformat}.{ seq MTEqn \c \*mergeformat})}

 

MathType 4.x - 5.x:

{MACROBUTTON MTEditEquationSection2{SEQ MTEqn \r \h \* MERGEFORMAT}{SEQ MTSec \r 1 \h\*MERGEFORMAT}}
{ macrobutton MTPlaceRef \*mergeformat{ seq MTEqn \h \*mergeformat}({ seq MTSec \c \*mergeformat}.{ seq MTEqn \c \*mergeformat})}
{ macrobutton MTPlaceRef \*mergeformat{ seq MTEqn \h \*mergeformat}({ seq MTSec \c \*mergeformat}.{ seq MTEqn \c \*mergeformat})}
{MACROBUTTON MTEditEquationSection2{SEQ MTEqn \r \h \* MERGEFORMAT}{SEQ MTSec \r 1 \h\*MERGEFORMAT}}
{ macrobutton MTPlaceRef \*mergeformat{ seq MTEqn \h \*mergeformat}({ seq MTSec \c \*mergeformat}.{ seq MTEqn \c \*mergeformat})}
{ macrobutton MTPlaceRef \*mergeformat{ seq MTEqn \h \*mergeformat}({ seq MTSec \c \*mergeformat}.{ seq MTEqn \c \*mergeformat})}

 

 The field code,

{ { seq MTSec \h }{ seq MTEqn \r \h } }

or

{MACROBUTTON MTEditEquationSection2{SEQ MTEqn \r \h \* MERGEFORMAT}{SEQ MTSec \r 1 \h\*MERGEFORMAT}}

is what tells Microsoft Word to increment the section number and to reset the equation number back to 1.

You will need to turn Microsoft Word's Field Codes on, locate and delete the second section field code (bolded above for easier recognition), turn Microsoft Word's Field Codes off , highlight the area affected (everything below the section field code that you delete), and press F9 in Microsoft Word (Update Field Codes). This will change the entries to:

w/ section #'s:

(1.1)
(1.2)
(1.3)
(1.4)

w/out section #'s:

(1)
(2)
(3)
(4)


 

Changing Section Numbering

 

MathType 3.x

If you want to start section numbering at a number other than 1, this can be accomplished in two ways:

  1. You can insert as many equations sections as needed by selecting Equation Section from Microsoft Word's Insert menu:

{ { seq MTSec \h }{ seq MTEqn \r \h } }
{ { seq MTSec \h }{ seq MTEqn \r \h } }
{ { seq MTSec \h }{ seq MTEqn \r \h } }
{ { seq MTSec \h }{ seq MTEqn \r \h } }

...producing a equation number that will look like: (4.1)

  1. You can manually edit the field code to read:

{ { seq MTSec \r 4 \h }{ seq MTEqn \r \h } }

...where: \r # = reset to defined number (#); no number = 1

Once you make the change, highlight it and all the remaining portion of your document and press the F9 key (Update Field Codes) producing an equation number that will look like: (4.1)

MathType 4.x - 5.x

If you want to start or modify section numbering at a number other than 1, do the following:

  1. Choose "MathType" from the top menu in Microsoft Word.

  2. Choose "Insert Chapter/Section break..." or "Modify Chapter/Section break..."

  3. Enter the appropriate changes and click "OK".


Changing Equation Numbering

If you want to start equation numbering at a number other than 1, this can be accomplished by manually editing the field code to read:

Microsoft Word 2.0, 6.0, 95:

{ commandbutton MTPlaceRef { seq MTEqn \h }({ seq MTSec \c }.{ seq MTEqn \r 4})}

Microsoft Word 97 - 2004:

{ macrobutton MTPlaceRef \*mergeformat{ seq MTEqn \h \*mergeformat}({ seq MTSec \c \*mergeformat}.{ seq MTEqn \r 4 \*mergeformat})}

...where: \r # = reset to defined number (#); no number = 1

Once you make the change, highlight it and all the remaining portion of your document and press the F9 key (Update Field Codes)...

...producing an equation number that will look like: (1.4)


Changing Section AND Equation numbering

Both methods described above can be used in conjunction with each other.

Microsoft Word 2.0, 6.0, 95:

{ commandbutton MTPlaceRef {seq MTEqn \h}({seq MTSec \r 4}.{seq MTEqn \r 4})}

Microsoft Word 97:

{ macrobutton MTPlaceRef \*mergeformat{ seq MTEqn \h \*mergeformat}({ seq MTSec \r 4 \*mergeformat}.{ seq MTEqn \r 4 \*mergeformat})}

Once you make the change, highlight it and all the remaining portion of your document and press the F9 key (Update Field Codes)...

...producing an equation number that will look like: (4.4)

All subsequent section and equation number additions will increment from the new hand-coded value.

The '\' is used to denote Microsoft Word identifiers used with the commands, specifically the sequence (seq) command. If you would like more information on WordBasic commands and their identifiers, please consult your Microsoft Word manual or help file.


Top of page

TechNotes Home   |   TechNote Wizard   |   Contact us

Copyright © 1996-2014 Design Science. All rights reserved.
Privacy statement
Follow MathType: