Skip NavigationDesign Science: How Science Communicates
Products Solutions Store Support Reference Company View Cart
 
 
TechNote #58: Last modified: 02/19/04
Last reviewed: 02/19/04

Installing MathType 3.5 Macros into Microsoft Word 97 and 2000


The information in this document applies to:

MathType 3.5 (Windows)

Microsoft Word 97 (Win)
Microsoft Word 2000 (Win)

Issue

MathType 3.5 comes with a template document containing macros which add a number of new features to the Insert and Tools menus of Word as well a button to the Standard toolbar for inserting MathType equations.

The current version MathType automatically installs the macros into Microsoft Word 97 and 2000, so manual installation is not required. The current version also includes an improved and expanded set of macros which have been tested with Word 2000 and includes an add-in for PowerPoint which adds a toolbar button to PowerPoint's toolbar for inserting a MathType equation.

Note: If you have MathType 3.1 or earlier, it is necessary to upgrade your version of MathType if you want macros which are compatible with Word 97 or 2000. If you have Office/Word XP (2002) or later you will need to upgrade to our latest version of MathType.


Solution

1. Installing the macros in Microsoft Word 2000

2. Installing the macros in Microsoft Word 97


Installing the macros in Microsoft Word 2000

MS Word 2000 has a default macro security setting which prevents you from installing macros to protect you from infecting your Normal template with macro viruses. 

  1. Under the Tools menu of Word, choose Macro, and then Security. The dialog below will open.

  1. Change your security setting to 'Medium'. 
  2. You should then be able to install the macros in CMDMSW97.DOC per the instructions below for Word 97.
  3. After installing MathType's macros, return your macros Security to "High" for the strongest protection.

Installing the macros in Microsoft Word 97

  1. Launch Microsoft Word.
  2. The macros for Microsoft Word 95 are in a Word document titled CMDMSW95.DOC. The macros for Microsoft Word 97 are in CMDMSW97.DOC. Under the File menu of Word select Open to open the file for your version of Microsoft Word. These files are located in your MathType directory.
  3. You may receive a warning message because the file contains macros. Microsoft Word 97 users will see the dialog below. The dialog for Word 2000 is similar.

  1. Click Enable Macros. The document will open.
  2. About a third of the way through the document, you will find the box below.

  1. Double click on this gray box in the Word document to begin installation of the macros.
  2. You will see a dialog asking you if you want to add a toolbar for inserting MathType equations to be placed on your Word toolbar, shown below.

  1. Click Yes. You will then see a dialog asking you if you want to install all of MathType's macros, shown below.

  1. Click Yes. You will then see a dialog asking you if you want to install the macros globally, shown below.

  1. The macros will be copied to Normal.dot, Microsoft Word's Normal template and the dialog below will be displayed, confirming that the macros were successfully installed.

  1. Press OK.

The macro installation is complete. New commands will appear in the Insert and Tools menus of Microsoft Word and a button should appear on the Standard toolbar of Microsoft Word.


Top of page

TechNotes Home   |   TechNote Wizard   |   Contact us

Copyright ©1996-2018 Design Science, a Wiris company. All rights reserved.
Privacy statement
Follow MathType: