Skip NavigationDesign Science: How Science Communicates
Products Solutions Store Support Reference Company View Cart
 
 
TechNote #: 92 Last modified: 09/21/01
Last reviewed: 09/21/01

MathType 4.0 Guide for IS Professionals


The information in this document applies to:

MathType 4.0 (Win) site licenses


Issue

Many customers who have purchased site licenses for MathType would like to know how to install MathType on a server so that it can be controlled by their metering software and can be accessible to all the users on their network.


Reason

This document is designed to familiarize network administrators and the like with issues concerning the MathType application’s installation, and some specialized features designed to make the installation of MathType on multiple machines as painless as possible.


Solution

This notice addresses the following topics:

1. Installation Overview

2. Installing MathType for multiple users

3. Setup's Command-line Interface

4. Files not in the MathType Folder

5. Sharing a MathType Installation Across a Network


Installation Overview

MathType Setup has been designed to run from one of a number of disk types. It can run from a CD, from a set of floppies, or from a self-extracting executable (for download).

There are 2 different types of installation. There is a standard installation, and a "Workstation Install", which sets up MathType to run from a shared location on a server. Most of the time, users will perform a normal installation. However, if there is a need to preserve disk space on the bulk of users' machines, or to assist in metering concurrent usage, MathType can be installed to a server, and all users can share that installation. This is discussed in detail in the section entitled Sharing a MathType Installation Across a Network.

Setup will check the versions of files that it is installing, and will only install them if the version is the same or newer than that of the existing file. Files with the following extensions will be version-installed: DLL, EXE, and TTF. File types that don't contain version data will always be installed, and will overwrite existing files.

Setup writes a log file ("MathType.log") into the user's Windows folder. This log file contains a large amount of information pertaining to the most recent run of Setup. All the files that were installed, and all the tasks that were performed (e.g. OLE registration, font installation, etc.) are listed here in the log. All messages that are presented to the user are also written into the log file. This includes error and warning messages, as well as messages displayed in the progress meter dialog. This same log file is used during a removal, or uninstall, of MathType.

The file SETUP.EXE is a tiny file (later referred to as the "stub" or "stub app") whose job is to pop up a small, buttonless message box, uncompress the main installation application (DSSETUP.EXE), and launch it, at which time the message box is removed. The stub always passes the "-S" command-line parameter to the installer (see below for details).


Setup's Command-line Interface

Command-line parameters can be passed to the Setup application, SETUP.EXE. These parameters will be passed to the main setup application. Some of these parameters require a folder location. Folder locations must be surrounded by double-quotes if the path name contains spaces. All command-line parameters are case-insensitive. All parameters, including extra path parameters, should be separated from each other by a space, for example:

Setup.exe -D "E:\User Apps\Design Science\MathType" -W
-D This parameter indicates the destination folder. Following this parameter must be the full path of a folder where MathType will be installed. This folder will be displayed in the "Install MathType to:" box on the main selection dialog.
-DL This parameter is the same as the "-D" parameter, except the user will not be able to edit the destination location in the main selection dialog. Using this command-line parameter will disable, or lock, that dialog control.
-S This parameter indicates the source folder. Following this parameter must be the full path of a folder where the MathType source files are located. Only use this parameter if you are directly calling DSSETUP.EXE. The stub (SETUP.EXE) automatically uses this parameter when calling DSSETUP.EXE, and it is an error to use the same parameter twice.
-W This parameter indicates that Setup should switch modes, and perform "Workstation" installations and removals. See below for details.
-I This parameter indicates that Setup should skip the main selection dialog. This parameter is especially useful when used in combination with the "-D" or "-DL" parameters. The user is not presented with the option to modify the destination folder for the application, and will not be able to exit Setup short of aborting installation while the files are being copied/uncompressed.
-R This parameter indicates that Setup should only be run in "remove" mode. If "-R" is passed on the command-line, the user will not have the option of installing MathType.
-C This parameter is used to suppress error and warning messages relating to macro command installation. If MS Word's Startup folder is locked, or if the macro command files have already been installed and are locked, Setup will normally give the user warnings on installation. If this is the normal environment for your organization, and you don't want users to have to deal with such messages (and report these errors to you), use this switch. Be aware, however, that if the macro command files are not already installed, and Word's Startup folder is locked, your users will not see the appropriate warning messages, and will not have the macro commands available to them. For this reason, the "-C" switch should be used sparingly, and generally in combination with the "-W" switch. If this switch is on, these errors and warnings will be written into the log file.
-OLEMGR This parameter is used to put Setup in "OLE Management" mode. This brings up the "Equation Conversion Manager" dialog. In this mode, users will be able to configure which equation types will be auto-converted to MathType 4. While in this mode, no files will be copied or uncompressed. It is solely used to manage equation types and the applications that are used to edit them.


Files not in the MathType Folder

The bulk of the files that are installed by MathType Setup are placed into a directory structure in the application directory (also known as the "MathType folder"), which is chosen by the user in the main selection dialog at the beginning of installation. However, some files are kept in other locations. In general, Setup needs to have write access to these other locations in order to successfully install MathType. These files and their locations are described below.

Word Commands

MathType Setup installs macro commands for Word 95, Word 97, and Word 2000 by placing a template (.dot) file in the appropriate startup folder for each version of Word that is installed on the machine. In addition, the template itself completes the macro command installation the next time Word is run. If these folders are locked, Word macro commands will not be installed successfully. At a minimum, these folders must be unlocked and available during installation, and the next time Word is run after that installation. In other words, if you normally operate with Word's startup folders locked, you'll need to unlock these folders, run MathType Setup, run each version of Word, and then re-lock the startup folders.

Copies of all of these macro command template files are stored in MathType's "Office Support" sub-folder. The macro commands can be installed manually into Word by simply copying the appropriate file from this location into Word's startup folder, and then running Word to complete the installation.

Other Files

TrueType Fonts TrueType fonts are installed to the standard Windows Fonts folder.

A copy of all the TrueType font files is also kept in a subfolder of the MathType folder. This subfolder is Fonts\TrueType.

System-level DLLs MathType Setup installs a DLL that is used by MathType’s help file. This file is generally installed to the Windows System folder.
Toolbar File MathType maintains a file that contains the contents of the user’s customizable toolbar. This file is located in the "Design Science\DSMT4" folder beneath the "Application Data" folder. This allows users to have their own toolbar that will be kept along with their user profile (on systems that support profiles). This means that if a user's profile is stored on a server, rather than kept locally on each computer, the same MathType toolbar will be available from any computer he or she logs on to.
Application Log File This file contains any errors that may have been generated by MathType’s translators. This file is located beneath the "Application Data" folder, in the same folder that contains the toolbar file.
Start Menu Shortcut Files Like most installers, MathType Setup creates a set of shortcut files to the MathType application, help file, and Setup. These files are created under the "Start Menu\Programs" folder, in a folder called "MathType 4".


Sharing a MathType Installation Across a Network

Overview

MathType Setup supports a "Workstation Install", which is designed to allow you to install MathType to a central location on the server, and have all your users share that one copy. The workstation install will perform a minimal set of tasks (e.g. font installation, OLE registration, and installing shared, system-level DLL's), and will not need to, for example, uncompress the MathType.exe file to the user's system because it will already exist on your network drive. This process may assist you in metering the number of concurrent users of MathType, possibly preventing you from violating your MathType license agreement.

Before your users can run a workstation install, you need to complete the following steps:

  • Copy contents of MathType CD to server
  • Run a normal MathType Setup
  • Create the shortcut your users will run

Please read through the steps before starting.

Steps to Perform:

  1. Copy contents of MathType CD to server

    Copy the contents of the MathType CD to a location where all users will have access to it. Once this step is complete, this folder can be locked. This folder is referred to as the "source". If you have floppy disks, simply copy all the files from each of the floppies into a single folder.

  2. Run a normal MathType Setup

    Setup needs to be run once in order to set up the MathType destination folder. Install MathType to a location on your server that all your users will normally be able to access. Do not install into the source folder (created in step 1). These two folders must be kept separate, or Setup will fail. During this step, you will be required to personalize the copy of MathType by entering a name, organization (optional), and registration number. The name field should contain the name of the licensee as stated in your contract. The registration number must be a valid site-license registration number, or you will run into problems in step 4.

    During this normal install, there are some issues you may need to keep in mind. Not all of the files that are installed go into the MathType folder (or its subfolders). For example, MathType Setup installs macro commands for Word 95, 97, and 2000. These files go into the appropriate startup folder for the version of Word. If you run Word with its startup folders locked, you will need to unlock these folders to permit MathType Setup to complete successfully. For further details, see the section entitled Files not in the MathType Folder.

  3. Create the shortcut your users will run

    Create a shortcut to the Setup.exe file (located in the source folder), and put it where your users will be able to run it. Name this shortcut "MathType Workstation Install".

    Open the "Properties" dialog for this shortcut. On the "Shortcut" tab, edit the "Target:" box and add the following text at the end: -W -DL "<MathTypeDir>" (where MathTypeDir is the location where you already have MathType installed from step 2). This path can either be a mapped network drive, or a UNC path name. If you normally run Word with its startup folder locked, you might want to consider also adding "-C" to the command-line in order to suppress the error messages your users will get during a workstation install. Note: using the "-C" command-line parameter may prevent you from receiving valid macro installation errors. Use this parameter sparingly.

  4. Run Workstation Install

    You are now ready to run and test your Workstation Install. From another machine, launch the "MathType Workstation Install" shortcut, and complete the installation. You should now have all the proper fonts, OLE registration, and the Start Button icons for MathType. To test that the installation was successful, simply run MathType from the Start Button. Insert a few symbols and templates from the palettes on the toolbar, and a few expressions from the large and small expression bars (also on the toolbar).


Installing MathType for Multiple Users

MathType 4's installation on Windows NT, 2000 or XP is profile-specific, that is, all files are not installed for all users on a computer. For this reason, several steps are required beyond a standard installation in order for MathType 4 to be accessible for multiple users on a Windows NT, 2000 or XP computer. MathType 5, meanwhile, installs for all users on all of the above platforms and requires no further steps beyond a standard installation.

In order for all users to have access to the MathType 4 Start menu group, which provides the user with MathType's pre-defined program shortcuts, and the MathType Commands for Word 2000, which provide the user with several high-level MathType macros and commands in Word 2000 and 2002 (XP), you have two options:

1. Install MathType under every profile on the computer

This would ensure that all users who login to the computer will have access to the MathType Commands in Word, but it also means that Administrator's will have to grant temporary permissions to each user who does not have the correct level of permissions to install, and this can be a time-consuming task.

2. Manually moving files to other profiles

To install the MathType Commands for Word 2000 in other profiles:

  1. Before manually configuring individual profiles, make sure you can view hidden files. Launch Windows Explorer and choose Tools>Folder Options. Click on the View tab. Make sure that under "Hidden files and folders", you have selected "Show hidden files and folders". Click OK.
  2. The default location of the Word startup folder for a profile is:
    C:\Documents and Settings\[userid]\Application Data\Microsoft\Word\STARTUP
    where [userid] is the user's login ID. The Application Data folder is a hidden file under Windows 2000 by default so you must be able to view hidden files to open it.
  3. Launch Windows Explorer and open the Office Support folder in your MathType folder. There is a copy of MathType Commands for Word 2000.dot in it. To place a new copy of MathType Commands for Word 2000.dot into a Word Startup folder, right-click on it and choose copy. Then, right-click on the Word 2000 startup folder and select paste. You want to place a copy there, rather than moving the file, so that you retain a spare copy, should you need it later.
  4. Follow step 3 for all other profiles on the computer that you want to have access to the MathType Commands for Word 2000

To install the MathType Start menu group for all users:

  1. Launch Windows Explorer and navigate to C:\Documents and Settings\[userid]\Start Menu\Programs, where [userid] is the profile under which you installed MathType 4.
  2. Find the MathType 4 folder and right-click on it and choose Cut.
  3. C:\Documents and Settings\All Users\Start Menu\Programs and then choose the Edit menu and click Paste. This will add the MathType 4 program group to the Start Menu for all users who login to the computer.

MathType 5 solves both of these issues by automatically installing both the MathType Commands and the MathType 5 Start Menu items for all users.


Top of page

TechNotes Home   |   TechNote Wizard   |   Contact us

Copyright © 1996-2018 Design Science. All rights reserved.
Privacy statement
Follow MathType: