Skip NavigationDesign Science: How Science Communicates
Products Solutions Store Support Reference Company View Cart
 
 
TechNote #1: Last modified: 02/28/01
Last reviewed: 02/28/01

Installing the MathType 3.x Macros into Non-English Versions of Microsoft Word


The information in this document applies to:

MathType 3.x (Win)

Microsoft Word 1.0 (Win)
Microsoft Word 2.0 (Win)
Microsoft Word 6.0 (Mac)
Microsoft Word 6.0 (Win)
Microsoft Word 95 (Win)

If you are installing MathType 3.5 or earlier and you are running a non-English version of Word, you will need to make some minor changes to the macro file included with MathType if you've selected it as part of the installation. This notice does not apply to users of MathType 3.6 or 3.7 for the Macintosh or MathType 4.0 for Windows. Please be aware that if you are using Word 97, you may not need to make such changes to the macro file. Install the macros before attempting to make changes to the file and see if they are necessary. The actual name of this macro file will vary depending on the version of Word you are using; take a look at the chart below to verify the proper file to use:

If you use Word version...

MathType 3.0e and earlier...

MathType 3.1, 3.1a...

MathType 3.5

Word 2.0 (Win) WW2MACRO.DOC WW2MACRO.DOC CMDMSW2.DOC
Word 6.0 (Win) WW6MACRO.DOC WW6MACRO.DOC CMDMSW6.DOC
Word 6.0 (Mac) MathType Commands for Word
Word 95 N/A WW7MACRO.DOC CMDMSW95.DOC
Word 97 N/A N/A CMDMSW97.DOC

 


Finding the MTLib Macro

Once you have determined the proper file to use with your version of Word, you will need to edit a specific macro within the file:

  1. From the File menu, click Open. Once you've determined the location of the macro file (i.e., CMDMSW97), double-click its icon to launch the file.
  2. You'll see from the Tools menu, click Macro... (Word 97 users will need to subsequently select Macros...)
  3. At the bottom of this new dialog, you'll see an entry to select which location you would like to open any macros.  Make sure that the correct file name of the macro is selected.
  4. Now, under the heading, "Macro name," you'll see a list of the macros that are included with this file. Scroll down the list, and click once on the entry, "MTLib.MAIN". Click Edit.
  5. Scroll down to a point just after the end of the paragraph entitled, "Note For Users of Non-English..." A list of the various commands that MathType uses will be shown. The commands appear in quotation marks (i.e. "gotobutton"), and are preceded by the listing, "Local$(##)". 

Editing the MTLib macro

Now that you've found the entries that need to be changed, you will need to compare the list that appears in the "MTLib" macro with the list below. You will probably find that some of the words listed below are the same in your language. If so, make a note of this--you will NOT need to edit these.

Below are the words that are needed to change in order to localize the MathType macros for non-English versions of Word for Windows 6.0, 95, and 97 and Word for Macintosh 6.0.x.

NOTE: Depending on which version of Word you are running, you may not use all of the listed translations.


Field Types

            Macrobutton       gotobutton      ref     seq     eq

French      Boutonmacro       Boutonatteindre Renv    séq     Eq
German      MAKROSCHALTFLÄCHE GEHEZU          REF     SEQ     FORMEL
Spanish     botónmocro        botónira        ref     sec     ec
Portuguese  macroind          irparaind       ref     seq     igual
Swedish     makroknapp        gċtillknapp     ref     sekv    eq
Italian     pulsmacro         pulsvaia        rif     seq     eq
Dutch       macroblokje       ganaarblokje    verwzg  reeks   vergelijk
Danish      MAKROKNAP         HOPKNAP         HENVIS  SEKVENS FORMEL
Finnish     makropainike      siirrypainike   viit    järjnum kaava
Norwegian   MAKROKNAPP        GĊTILKNAPP      REF     SEKV    FO
Japanese    

Number Conversion

            roman      Roman      alphabetic    Alphabetic

French      romain     Romain     alphabétique  Alphabétique
German      römisch    Römisch    alphabetisch  Alphabetisch
Spanish     romano     Romano     alphabético   Alphabético
Portuguese  romano     Romano     alphabètico   Alphabètico
Swedish     roman      Roman      alfa          Alfa
Italian     romano     Romano     alfabetico    Alfabetico
Dutch       romeins    Romeins    alfabetisch   Alfabetisch
Danish      romertal   Romertal   alfabetisk    Alfabetisk
Finnish     roomal     Roomal     aakkonen      Aakkonen
Norwegian   romertall  Romertall  alfabetisk    Alfabetisk
Japanese    

Command Name Conversion

            InsertEquation           EditPicture

French      InsertionEquation        EditionImage
German      EinfügenFormel           BearbeitenGrafik
Spanish     InsertarEcuación         EdiciónImagen
Portuguese  InserirEquation          EditarFigura
Swedish     InfogaFormel             RedigeraBild
Italian     InserisciEquazione
Dutch       VergelijkingInvoeren     FiguurBewerken
Danish      IndsĉtLigning            RedigerBillede
Finnish     LisääKaava               MuokkaaKuva
Norwegian   SettInnLigning           RedBilde
Japanese    

Other Conversions

            Separator    Menu Bar        Tools   Insert     ^g  ^d  NORMAL

French      (Séparateur) Barre de menus  Tools   Insert     ^g  ^d
German      (Trennlinie) Menüleiste      Extras  Einfügen   ^r  ^d
Spanish     
Portuguese  
Swedish     
Italian     
Dutch       
Danish      
Finnish     
Norwegian                 Menylinje      Verktĝy Sett inn    ^g  ^d
Japanese                                              

Note: The \StartOfSel and \Sel commands mat not need to be localized. Leave these commands as is unless you have problems with the Update Equations command.

If an entry in the above listings is blank, we have not been able to determine the correct localized translation for the command at this time. If you have any information concerning translations of any blank entries above, please forward your comments to support@dessci.com.


And Finally...

Once completed, go to the File menu and select Save. You may or may not receive a message asking if you'd like to keep the changes for the macro. Make sure to click "Yes," to this dialogue, if received. Close the screen from the File menu. You may now proceed to install the macros as outlined in Tech Support Notice #58.


Top of page

TechNotes Home   |   TechNote Wizard   |   Contact us

Copyright ©1996-2018 Design Science, a Wiris company. All rights reserved.
Privacy statement
Follow MathType: