Skip NavigationDesign Science: How Science Communicates
Products Solutions Store Support Reference Company View Cart
 
 
TechNote #124: Last modified: 06/22/2007

Creating a Quick Access Toolbar button in Word 2007 to open Equation Editor


The information in this document applies to:

  • Microsoft Word 2007 (Windows)

 


Issue

Most users insert Equation Editor equations by choosing the Insert Object command on the Insert tab. You then see a list of objects you can insert into your document, and double-clicking "Microsoft Equation 3.0" launches Equation Editor. There is an easier way! You can add a button to the Quick Access Toolbar in Word. Clicking this button will allow you to insert a new equation into your document with a single click.


Solution                         

Adding a button that opens Equation Editor is a simple two-part process. Step one is recording the macro, and step two is adding your recorded macro to the Quick Access Toolbar.

  1. Recording the Macro:

    1. Open Word and click on the View Tab.

    2. In the Macros group, click the Macros button  and choose Record Macro

    3. In the resulting Dialog name your macro EquationEditor and choose All Documents (Normal.dotm), under Store Macro in:

    4. Click OK to begin recording.

    5. Click the Insert Tab in Word's Ribbon.

    6. Click the button labeled Object, located in the Text Group to open the Insert Object Window.

     

    1. Click on Microsoft Equation 3.0 and click OK.

    2. This will open Equation editor.

    3. Click anywhere on the Word document to return to normal display of the Word Ribbon and then click on the View tab.

    4. Click on the Macros button and choose Stop Recording.

    5. The Macro has been recorded.

  1. Adding your recorded macro to Word's Quick Access Toolbar: The Quick Access Toolbar located in the upper-left portion of the Word window, is a customizable toolbar into which you can place buttons for your frequently used commands and of course, macros.

  • Adding your newly created macro to the Quick Access Toolbar:

    1. Right-click on the Quick Access Toolbar and choose, Customize Quick Access Toolbar... to open the customization dialog.

    2. From the pull-down menu labeled Choose commands from: select Macros.

    3. Click once on the macro name Normal.NewMacros.EquationEditor.

    4. Click the Add button.

    5. Optional: You can click the Modify button to apply an icon of your choice to this button.

    6. Click OK.

    7. You now have the macro button for Equation Editor located in the Quick Access Toolbar. Any time you wish to insert an equation at the cursor simply click the button in the Quick Access Toolbar and Equation Editor will open ready for you to begin typing your equation.

 


Top of page

TechNotes Home   |   TechNote Wizard   |   Contact us

Copyright © 1996-2014 Design Science. All rights reserved.
Privacy statement
Follow MathType: