Skip NavigationDesign Science: How Science Communicates
Products Solutions Store Support Reference Company View Cart
 
 
TechNote #127: Last modified: 11/03/2016

Setting default font preferences for MathType in Pages, Keynote, and Numbers


The information in this document applies to:
 

  • MathType 6.x (Macintosh)
  • macOS 10.4.9 and later
  • Apple iWork '09
  • Apple Pages 5, Keynote 6, Numbers 3 (and later)

Issue:

Style and Size definitions in MathType are not respected with each new instance of MathType when called from the iWork '09 apps, and their successors Pages 5.x, Keynote 6.x, and Numbers 3.x, and later.


Reason:

These default placeholder equations are actually saved equations that fix the properties for font, size and style, that are used by these applications to open MathType. Since this causes MathType to load saved equations, the "save for new equations" mechanism doesn't apply.


Solution:

We recommend saving default equations that contain the font, font size, and font attribute settings that are appropriate for your work. You can save multiple files if you wish, but note that each file, when used, must have the correct file name and must be placed inside the application's package contents as detailed below.

Note: If you've upgraded from iWork to the versions of Pages, Keynote, and numbers first released in October 2013, the old iWork apps should still be in your Applications folder, in an iWork subfolder. These steps will work for both old and new versions of the apps.

Pages:

  1. If Pages is running, close it before proceeding.
  2. In a Finder window, go to your Applications folder and find the application icon for Pages. Control-click the application icon and from the contextual menu choose "Show package contents."

contextual menu for Pages

  1. From there navigate to Contents/Resources/
  2. If you're using:
    1. the iWork '09 version of Pages, locate the file named default_equation.pict
    2. Pages 5.0 or newer, locate the file named MathTypeEquation.pdf.
  3. Delete this file. Note: You may need an administrator password to do this.
  4. Launch MathType from the Finder (or Launchpad, or Dock).
  5. From MathType's Style Menu, choose Define.
  6. In the resulting dialog, choose your preferred font from the Primary Font drop-down menu.
  7. Be sure to include a check next to "Italic Variables" and "Italic lower-case Greek."
  8. Click OK.
  9. From the Size Menu choose, Define.
  10. Set the font size for Full to your preferred font size (it will normally be the same size as your document's text).
  11. Click OK.
  12. From the File menu choose Save-as.
  13. If you're using:
    1. the iWork '09 version of Pages, save the file using the Pict format and name it default_equation.pict.
    2. Pages 5.0 or newer, save the file using the PDF format and name it MathTypeEquation.pdf.
  14. Place this saved file into the folder noted in item 3 above. Note: You may need an administrator password to do this.
  15. Changes will take effect when you re-start Pages. No need to reboot.

    Note: If you wish, you can create multiple equations each containing different settings. To use any of those you must be sure that it's named as described in step 15 above, and placed in the resources under the Pages Package Contents.

Keynote:

  1. If Keynote is running, close it before proceeding.
  2. In a Finder window, go to your Applications folder and find the application icon for Keynote. Control-click the application icon and from the contextual menu choose "Show package contents."
  3. From there navigate to Contents/Resources/
  4. If you're using:
    1. the iWork '09 version of Keynote, locate the file named default_equation.pict
    2. Keynote 6.0 or newer, locate the file named MathTypeEquation.pdf.
  5. Delete this file. Note: You may need an administrator password to do this.
  6. Launch MathType from the Finder (or Launchpad, or Dock).
  7. From MathType's Style Menu, choose Define.
  8. In the resulting dialog, choose the font you normally use for slides from the Primary Font drop-down menu.
  9. Be sure to include a check next to "Italic Variables" and "Italic lower-case Greek."
  10. Click OK.
  11. From the Size Menu, choose Define.
  12. Set the font size for Full to match the font size used on your slides.
  13. Click OK.
  14. From the File menu choose Save-as.
  15. If you're using:
    1. the iWork '09 version of Keynote, save the file using the Pict format and name it default_equation.pict.
    2. Keynote 6.0 or newer, save the file using the PDF format and name it MathTypeEquation.pdf.
  16. Place this saved file into the folder noted in item 3 above. Note: You may need an administrator password to do this.
  17. Changes will take effect when you re-start Keynote. No need to reboot.

    Note: If you wish, you can create multiple equations each containing different settings. To use any of those you must be sure that it's named as described in step 15 above, and placed in the resources under the Keynote Package Contents.

Numbers:

  1. If Numbers is running, close it before proceeding.
  2. In a Finder window, go to your Applications folder and locate the application icon for Numbers. Control-click the application icon and from the contextual menu choose "Show package contents."
  3. From there navigate to Contents/Resources/
  4. If you're using:
    1. the iWork '09 version of Numbers, locate the file named default_equation.pict
    2. Numbers 3.0 or newer, locate the file named MathTypeEquation.pdf.
  5. Delete this file. Note: You may need an administrator password to do this.
  6. Launch MathType from the Finder (or Launchpad, or Dock).
  7. From MathType's Style Menu, choose Define.
  8. In the resulting dialog, choose your preferred font from the Primary Font drop-down menu.
  9. Be sure to include a check next to "Italic Variables" and "Italic lower-case Greek."
  10. Click OK.
  11. From the Size Menu, choose Define.
  12. Set the font size for Full to whatever size you want; we recommend 10 points.
  13. Click OK.
  14. From the File menu choose Save-as.
  15. If you're using:
    1. the iWork '09 version of Pages, save the file using the Pict format and name it default_equation.pict.
    2. Numbers 3.0 or newer, save the file using the PDF format and name it MathTypeEquation.pdf.
  16. Place this saved file into the folder noted in item 3 above. Note: You may need an administrator password to do this.
  17. Changes will take effect when you re-start Numbers. No need to reboot.

    Note: If you wish, you can create multiple equations each containing different settings. To use any of those you must be sure that it's named as described in step 15 above, and placed in the resources under the Numbers Package Contents.

After creating and saving the equation files as detailed above, open any of these applications and (making sure MathType is open first) from the Insert Menu choose MathType Equation. This will open MathType with an empty workspace and the font, font size and font attributes will be those that were created and saved to the empty equation file. You may now proceed with creating your math expressions as you would normally.


Top of page

TechNotes Home   |   TechNote Wizard   |   Contact us

Copyright © 1996-2017 Design Science. All rights reserved.
Privacy statement
Follow MathType: