Skip NavigationDesign Science: How Science Communicates
Products Solutions Store Support Reference Company View Cart
TechNote #: 83 Last modified: 09/15/11

Microsoft Word and PowerPoint 2000 Display Equations Slowly

The information in this document applies to:

MathType 6.x (Mac)
MathType 6.x (Win)
MathType 5.x (Win)
MathType 4.0 (Win)
MathType 3.5 (Win)
Microsoft Equation
Microsoft PowerPoint 2000 (Win)
Microsoft Word 2000 (Win)


Many users report that equations take unusually long to display when initially scrolling through a Word 2000 document or a PowerPoint 2000 presentation. This delay may be a number of seconds, or even minutes. After the first time an equation has been rendered on-screen, there is no longer any lag time before it displays on-screen. This problem is due to a bug in Microsoft Office 2000.

Note: This problem in Microsoft Office 2000 has been fixed in Microsoft Office XP (2002), so upgrading Microsoft Office will correct it.

This issue is distinct from the fact that additional time is required to launch Word after MathType has been installed. For information about that issue, please see our notice that discusses why Word Takes Longer to Launch After Installing MathType.


Word and PowerPoint 2000 create a number of temporary files. You may wish to read Microsoft's article about temporary files in Word 2000. When Word and PowerPoint 2000 are shut down normally, they remove these temporary files. If they crash, or are not shut down normally, these temporary files may not be removed and accumulate. Word and PowerPoint 2000 create a temporary file for every embedded graphic in a document that they display on-screen. Authors of documents and presentations with many equations may accumulate hundreds or thousands of temporary files very quickly if Word or PowerPoint crashes or is not shut down normally just once. This accumulation increases the time required by both programs to display MathType equations and other graphics in the Windows Metafile Format (WMF).


This notice addresses the following issues:

1. Ensuring you have adequate space on your hard drive

2. For Windows Me, Windows 2000, and Windows XP users

3. Removing temporary files created by Microsoft Word and PowerPoint 2000

4. Preventing this problem from recurring

Ensuring you have adequate space on your hard drive

To check the amount of available space on a hard drive, 

  1. Double-click on My Computer. 
  2. Right-click on your hard drive and choose Properties. 
  3. Under the General tab, the amount of free space you have will be displayed. 
  4. If you have less than 20% free space, you should attempt to free up additional space. 

Please refer to your Windows help files if you are unfamiliar with the basics of file management.

For Windows Me, Windows 2000, and Windows XP users 

The directory where Microsoft Office's temporary files are stored is hidden by default under Windows 2000, Me, and XP. To be able to view your temporary directory,

  1. Double-click on My Computer.
  2. From the Tools menu, choose Folder Options.
  3. Click on the View tab.
  4. Under "Hidden files and folders", choose "Show hidden files and folders".

Removing temporary files created by Microsoft Word and PowerPoint 2000 

Temporary files, by definition, are intended to be just that—temporary—and are not meant to be saved indefinitely.

Unfortunately, the Disk Cleanup utility included with Windows does not remove the temporary files created by Office 2000 that cause this problem, so standard disk maintenance procedures will not address this problem. Hundreds, or even thousands, of these files may be present on your computer. Deleting them will correct this problem.

  1. Quit all running programs.
  2. From your Windows Start menu, choose Search if you are using Windows 2000, Me, or XP or choose Find if you are using Windows 95, 98, or NT and search for Files or Folders. The Search Results window will open.
  3. In the "Search for Files of Folders named:", type in mso???.wmf
  4. Be sure to limit your search to your C drive or select  "All local hard drives" if your computer has more than one hard drive.
  5. Click the "Search Now" or "Find Now" button, depending on if you are using Windows 2000, Me, or XP or if you are using Windows 95, 98, or NT.
  6. When Windows has stopped searching, in the right pane of the Search Results window will be all the residual temporary files created by Word 2000.
  7. Click in the right Window and choose Edit>Select All or press Control+A to select all the temporary files found.
  8. Press the Delete key on your keyboard or right-click on the selected files and choose Delete.
  9. If a dialog appears asking you if you are sure you want to delete these files, click Yes.

Upon restarting Microsoft Word or PowerPoint 2000, you should find that equations appear quickly.

Preventing this problem from recurring 

The best way to prevent this problem from recurring is to make sure to always completely quit Word and PowerPoint 2000 before logging off or shutting down your computer. If you simply close and save your document, but leave either program running with no open documents when you shut down or log off your computer, temporary files will accumulate.

These temporary files typically accumulate as a result of Microsoft Word or PowerPoint 2000 crashing, since most users know better than to shut down Windows with applications running. If Microsoft Word or PowerPoint 2000 crashes when you are editing a document containing many equations, you should restart your computer, recover your document, quit all running applications, and delete the temp files using the method provided above, particularly if you were in the process of editing a document which contained 50 or more equations. Please contact Microsoft for help recovering data from a document or if Word or PowerPoint 2000 is crashing frequently. You may wish to view Microsoft's article regarding use of the Autosave Feature to prevent the loss of your work when Word crashes. We also provide a notice about troubleshooting Microsoft Word that you may want to refer to.

To reduce the frequency of crashes, make sure that you have visited the Microsoft Office 2000 Update page and fully updated Microsoft Office 2000. 

Optimize Word 2000's performance 

You may also wish to read and implement some of Microsoft's suggestions for optimizing Microsoft Word 2000, which will help make your installation of Word 2000 faster and more stable.

Getting This Problem Addressed by Microsoft

It's important for Microsoft’s customers to report their experience of this problem so that Microsoft can appreciathow widespread it is and appreciate the need to devote their programming resources toward resolving it. We’ve reported the details of this issue, including sample documents to Microsoft, and we encourage all users who experience this problem to do the same.