Skip NavigationDesign Science: How Science Communicates
Products Solutions Store Support Reference Company View Cart
 
 
TechNote #99: Last modified: 11/09/04

Resolving Issues Using the MathType Commands for Microsoft Word for Windows


The information in this document applies to:

MathType 6.x (Windows)
 
Microsoft Word 2002 and later (Windows)


Issue

Users may experience one or more of the following problems getting MathType to work correctly with Microsoft Word: 

  • The MathType toolbar and menu may be missing.
  • Error messages that occur when you insert or edit MathType equations
  • Crashes or freezes when using MathType within Word
  • Error messages when starting Microsoft Word
  • We have a number of other notices that address specific problems that you may experience when using MathType with Microsoft Word. Before following the steps outlined in this TechNote, please consider if one of the notices below addresses your problem specifically:


    Reason

    The MathType Commands for Word rely on Microsoft Office components to function correctly. If one or more of them are not working correctly, you may experience problems when you try to use the features provided by the MathType Commands for Word.


    Solution

    We have basic regimen of procedures that reliably corrects problems using the MathType Commands for Microsoft Word by eliminating problems with VBA, according to the version of Microsoft Office and the version of Windows that you are using. Refer to the sections appropriate to your configuration:

    1. Hidden folders
    2. MathType toolbar and menu missing
    3. Microsoft Office 2002 and 2003 for Windows
    4. Transferring Customizations from your old Word Normal template

    Hidden folders

    By default, many of the files are hidden that you will need to implement these instructions. You should change the Windows default so that hidden files are visible so that you can successfully fix the problem you are experiencing.

    Windows XP, Vista, and Windows 7
    1. Open a File Explorer/Windows Explorer window (aka "My Computer").
    2. Choose Tools > Folder Options.
    3. Click the View tab.
    4. Under "Hidden files and folders" make sure that "Show hidden files and folders" is selected.
    Windows 8 and later
    1. Open a File Explorer window
    2. Click the View tab.
    3. Make sure there's a checkmark to the left of "Hidden items".

    MathType toolbar and menu missing

    If MathType's toolbar and/or menu is missing in Word even after installing MathType, perform the following steps:

    1. Word 2002/2003: In the Tools menu, click Templates and Add-Ins and look for the item 'MathType Commands 6 for Word.dot' listed under the Global Templates window and be sure it is checked. Click OK and the MathType menu and toolbar should appear. If you do not see the MathType Commands 5 for Word.dot item, please continue below to manually install the MathType plug-in.
    2. Word 2007 and later: In Word Options (Office button in Word 2007, File tab in later versions), choose Add-ins, then Word add-ins, then Go. Look for the item 'MathType Commands 6 for Word 20XX.dotm' listed under the Global Templates window and be sure it is checked. Click OK and the MathType menu and toolbar should appear. If you do not see the MathType Commands 5 for Word.dot item, please continue below to manually install the MathType plug-in.
    3. Quit Word and all other Office applications.
    4. Locate your Office/Word Startup folder and open it. The typical default location of the Startup folder is,

      C:\Program Files\Microsoft Office\Office<version>\STARTUP (or custom location set per-user)

      If you changed the default location of Office during installation, reassigned your Startup folder, or are running Office from a network drive, your Startup folder may be in a different location. To find the custom location of your Word startup folder, launch Word and choose Options from the Tools menu. Click on the File Locations tab. Click on Startup, then click on Modify in order to see the full path. The folder may have a different name. Write the location of the Word startup folder down. If it is not listed, click Modify to choose the path.

    5. Open the C:\Program Files\MathType\Office Support folder and copy both the MathType Commands 5 for Word.dot and MathPage.wll files from this folder and paste them into the Office/Word Startup folder above.
    6. Launch Word. Click Enable Macro if prompted to authorize the Design Science / MathType macros.
    7. If the MathType toolbar and/or menu is still missing, choose Tools | Templates and Add-ins.
    8. Enable 'MathType Commands 5 for Word.dot' by checking the box to the left of it. Click OK.
    9. The MathType toolbar and menu should now appear. If not, please contact Technical Support.

    Microsoft Office 2002 (XP) and 2003 for Windows

    To resolve any problems in Microsoft Office, follow the steps below to remove MathType, delete your Word Normal template, reset VBA, use Microsoft Word's Detect & Repair tool, fully update Office, and reinstall MathType. This is sufficient to fix most problems in Word.

    To remove MathType,

    1. Choose Start>Programs>MathType>Remove MathType.
    2. If you had MathType shipped to you, after following the remaining instructions, you can use your CD-ROM to reinstall MathType.
    3. If you downloaded MathType and did not save a copy of the installer, you can download another copy of the installer from http://www.dessci.com/en/dl/default.htm when you are ready to reinstall MathType.

    Your Word Normal template contains any macros, styles, or menu and toolbar customizations that you have defined. If you rename or delete it, Microsoft Word will create a fresh one and Microsoft Word will be reset to its defaults.

    Unless you have defined styles or Autotext entries, written or recorded macros, or custom toolbars that you want to save, you should delete Normal template. You will need to redo any menu customizations. If you prefer to save customizations that you have made, rename your Normal template to Normal.bak and follow the instructions below for transferring Word customizations from your old Normal template.

    1. Quit all running programs, especially Microsoft Word.
    2. If you are using Windows 2000, Me, or XP, from the Start menu, choose Search>Files or Folders.
    3. If you are using Windows 95, 98, or NT, from the Start menu, choose Find>Files or Folders.
    4. Under Named, type normal.dot
    5. Under Look in, make sure that C: is selected, so you are searching your entire hard drive.
    6. Click Search Now or Find Now.
    7. Delete all normal.dot files that are found.
    8. Restart Word to create a clean copy of the Normal template.

    Visual Basic for Applications (VBA) is the language in which macros for Microsoft Word are written. The MathType Commands for Word add-in, which adds the MathType menu and toolbar to Microsoft Word, is written in VBA. If VBA is not functioning properly, you may receive error messages when launching Word, using the MathType menu or toolbar, or Microsoft Word may crash.

    1. Launch Microsoft Word.
    2. Choose Tools>Macro>Visual Basic Editor.
    3. After the Visual Basic Editor is open, choose Run>Reset.
    4. Nothing will appear to happen but VBA has been reset.
    5. Close the Visual Basic Editor.

    Microsoft Word 2000, 2002 (XP) and 2003 include a Detect and Repair tool. It will examine your Word installation and attempt to correct any problems that it can find.

    1. Put your Microsoft Office CD-ROM into your CD drive.
    2. Launch Word and choose Detect and Repair from the Help menu.
    3. Follow the instructions provided.

    You can download all available patches for Office 2000 and XP at http://office.microsoft.com/productupdates/. This web page will automatically determine which patches you need to install to fully update your installation of Microsoft Office. The URL is worth bookmarking in your browser and visiting occasionally to keep Microsoft Office fully updated and running smoothly.

    After doing the above,

    1. Restart your computer.
    2. Reinstall MathType from your CD-ROM, or if necessary by downloading another copy of the installer from our website at http://www.dessci.com/en/dl/default.htm.

    Transferring Word customizations from your old Normal template

    If you have customized Word and subsequently renamed your Normal template Normal.bak as outlined above, you can use the Organizer to migrate your styles, Autotext entries, macros, and custom toolbars to your new Normal template.

    1. On the Tools menu, click Templates and Add-Ins.
    2. Click Organizer, and then click the tab for Styles, Autotext, Toolbars, or Macro Project Items.
    3. To copy items to or from a different template or file, click Close File to close the active document and its attached template or to close the Normal template. Then click Open File, and open your new Normal template.
    4. Click the items you want to copy in either list, and then click Copy.

    After transferring all your customizations to your new Normal template and closing the organizer, you can delete Normal.bak. Some customizations such as deletions from the Standard menus and toolbars, will need to be redone.

    Copyright ©1996-2018 Design Science, a Wiris company. All rights reserved. | Privacy statement