Skip NavigationDesign Science: How Science Communicates
Products Solutions Store Support Reference Company View Cart
 
 
TechNote #17: Last modified: 10/20/99
Last reviewed: 10/20/99

Installation of MathType 1.1 Macros for Word for Windows 2.0


The information in this document applies to:

MathType 1.1 (Win)

Microsoft Word 2.0 (Win)

Introduction

Note: To use MathType 1.1 with Word 2.0, you may either use our Macros (which use the Microsoft DDE language) as described below, or use the traditional cut (or copy) and paste method (please see the Windows manual for information if you are unfamiliar with cut and paste). However, for the following reasons we recommend you do not use the macros: 1) they are slow and become even slower as the number of equations in the document increases, and 2) the DDE language has had reliability problems. Later versions of MathType use a faster and more reliable method called Object, Linking, and Embedding (OLE), and has a macro that converts your old MathType 1.x equations into newer objects.

Using the cut and paste method presents only one minor problem: equations pasted in-line into Word are too high relative to the base line of the text. To resolve this, they must be subscripted. To do this, first note that when an equation is copied to the clipboard in MathType, the lower left corner of the MathType window displays "B= <number>"; this is the proper amount to subscript the equation. Once the equation has been pasted into Word, simply click once on the equation, go to “Character” in the “Format” menu, and place this number in the “Subscript by” box.

This above process can be simplified by creating a simple keystroke macro in Word which opens the “Character” box for you and puts in a value. You could assign, for example, CTRL-1 to subscript 1 point, CTRL-2 to subscript 2 points, etc. Please refer to the Word manual on creating and storing these macros.

If you are already familiar with using the DDE Macros and/or do not want to use the cut and paste method, then please note the following comments and instructions:

A problem has come to light because the Word Macro Language was changed by Microsoft for Word 2.0, and the macros were originally written for version 1.X of Word. The result of this change is that the InstallMathType macro no longer adds the macros to the Insert menu correctly. Some minor editing needs to be done to correct this situation. To do this:

  1. Open Mathtype.doc in Word (the file is in the Mathtype directory after adding the macros under Custom Install in the MathType Setup Program).
  2. From the menu bar, choose "Tools" and then "Macro" from the list.
  3. Make sure the Template Macros button is selected, and then click once on "InstallMathType" from the list; then choose the "Edit" button.
  4. To the 3 lines that start with ToolsOptionsMenus, add ", .Context = 0" (comma space period Context space = space zero, with NO quotes) to the very end of the line (the line wraps around and is actually longer than "one line").
  5. From the menu bar, choose "File" and then "Save All" from the listing.
  6. Answer "Yes" to both the "...keep changes..." and "...save changes..." dialogs.
  7. Choose "File" from the menu bar and "Close" from the listing.
  8. Open Mathtype.doc. Then follow the directions for installation and lastly, again choose "File" from the menu bar and on the next two pages.

The following is a printout of the MathType.doc file that shipped with MathType 1.1a.


MathType 1.1a / MS Word for Windows Compatibility and Macro Installation

This document outlines the installation and use of the Microsoft Word for Windows macros we have provided that automate the interface between MathType and Word. After the macros have been installed, there will be two new commands on the Insert menu: "Paragraph (Display) Equation" and "In-line (Text) Equation". These commands use the macro facilities in Word to communicate directly with MathType via Windows' Dynamic Data Exchange (DDE) capabilities. This document contains an installation routine that will install the new menu items in Word and make MathType macros globally available.


Installation

Before installing the macros, you should verify the following settings.

If your version of Word is prior to 2.0:

  1. You must have Full Menus enabled. If you see the item 'Full Menus' on the View menu, select it. If the View menu has a 'Short Menus' item, do not select it; you are currently using Full Menus.
  2. Make sure there is not a check mark next to 'Field Codes' on the View menu.
  3. Select 'Preferences' from the View menu. The Preferences dialog box will appear. Make sure there is not a check in the box next to 'Show All *'. You may now install the macros.

If you are using Word 2.0:

  1. On the View menu, make sure there is not a check mark next to 'Field Codes'.
  2. From the Tools menu, choose 'Options'. The Options dialog box appears. Select the 'View' category. Under 'Non-printing Characters', make sure there is not a check in the box next to 'All'. You may now install the macros.

In order to install these macros and menu items, you must double-click on the 'Install MathType Macros' button. This will copy macros from this document to the global area (Normal.dot) and install the new menu items. This may take about a minute, and there will be a lot of flashing on your screen. The installation procedure will inform you when it is done.

Users of non-English versions of Word should see the important information at the end of this document before proceeding.


Creating a New Equation

First, make sure the MathType application is running. The easiest way to set this up is to run MathType the normal way, and then minimize the "Untitled 1" window that opens. Whenever you want to insert a MathType equation in your document, just place the insertion point where you want the new equation and choose Paragraph Equation or In-line Equation from the Insert menu. Paragraph Equation will create an equation that is to be by itself between blocks of text (also known as a "display equation"); In-line Equation will create an equation that will be embedded in the text line so that the equation's baseline aligns with the surrounding text (also known as a "text equation"). Choosing either one will cause MathType to open a new window, ready for you to enter the equation.

The window that MathType opens is a special Edit window. This window is identical in every way to a 'normal' MathType window, except for the 'Save' and 'Close' options. These options will save the macro to the insertion point in your document, not to a separate file. When closing the window, answering 'Yes' to the save question will copy your equation back into your document; answering 'No' will not. 'Save' will paste a copy of the equation in your document and leave you in the MathType editor.

If equations in your Word documents display as simple boxes, either the 'Pictures' display is turned off (Word 1.1), the 'Show Text with Picture Placeholders' setting is turned on (Word 2.0), or Draft mode is turned on. Draft mode is in effect if there is a check next to 'Draft' on the View menu. To turn off Draft mode, select 'Draft' to remove the check.

To change Word 1.1's 'Pictures' display setting, choose 'Preferences' from the View menu; the Preferences’ dialog box appears. Check the box next to 'Pictures'.

To change Word 2.0's 'Show Text with Picture Placeholders' setting, choose Options from the Tools menu: the Options dialog box appears. Select the View category. Under 'Show Text with', make sure there is not a check next to 'Picture Placeholders'.


Editing an Equation

When you want to make changes to an equation in your Word document, just double-click on it. MathType will open a new window, the equation will be pasted into it, and then you can make your changes. The window will have the same functionality as described under 'Creating a New Equation.' When you are finished, close the window and respond 'Yes' to the save question. The equation will automatically be copied to the clipboard and pasted into the document, replacing the original equation.

You may edit several equations at the same time. MathType will give a unique number to each open equation which it will display as the window title. These numbers are not true equation numbers and are not intended to be used to mark equations for reference in the document. They are simply used to identify equations during the editing process. After the number reaches 99, it will start over at 1.

If Word's 'Field Code' display is turned on, double-clicking on an equation will not work properly. Before editing an equation, make sure there is no check next to 'Field Codes' on the View menu.


Implementation

The equation creation and editing features described here are implemented using a combination of Word macros, fields, bookmarks, and glossary features. The macros engage in DDE (Dynamic Data Exchange) conversations with MathType. Details on MathType's DDE support may be found by reading the Dynamic Data Exchange section of MathType Help. This section is located under Compatibility in the Help index. For in-depth information, select DDE.TXT from within the Dynamic Data Exchange Help topic.

These macros may be extended to perform such feats as automatic equation numbering and equation centering. If you want to modify the macros, you will need to understand the Word BASIC macro language and the DDE mechanism.


Note for Users of Non-English Versions of Word

There are three changes that must be made to the macros in order for them to function properly with your non-English version of Word. To make these changes you must edit macros contained in the WWMacros.doc document. Users of Word 1.1 should choose 'Edit...' from the 'Macro' menu and then make sure 'Context' is set to 'Template'. Users of Word 2.0 should choose 'Macro...' from the 'Tools' menu and then make sure 'Show' is set to 'Template Macro'. You will then see a list of the 8 macros contained in the document. Among them you will see "InstallMathType", "NewDispEqn", and "NewTextEqn". These are the macros that must be edited. To edit the macro, click on the 'OK' (Word 1.1) or 'Edit' (Word 2.0) button.

First, you should edit "InstallMathType". See the information for Users of NON-ENGLISH versions of Word near the beginning of the macro file and follow the instructions. You will need to know the name of the 'Insert' menu in your language.

Both "NewDispEqn" and "NewTextEqn" require the same change. See the information for Users of NON-ENGLISH versions of Word near the beginning of the document and follow the instructions for both macros. You will need to know the name of the "macrobutton" type of field in your language. Some language translations of Word Basic Macro names are available from Design Science.

After the changes have been made to all three macros, you should save MATHTYPE.DOC so that you will have these changes available in the future, should you need them.

Now you may continue the installation according to the instructions above.


Top of page

TechNotes Home   |   TechNote Wizard   |   Contact us

Copyright © 1996-2014 Design Science. All rights reserved.
Privacy statement
Follow MathType: