Skip NavigationDesign Science: How Science Communicates
Products Solutions Store Support Reference Company View Cart
 
 
TechNote #69: Last modified: 11/01/2016

Using MathType with Adobe Acrobat to Create PDF Files


The information in this document applies to:

MathType 6.x (Windows and Mac) Adobe Acrobat

Issue

Many people use Adobe Acrobat to create PDFs from documents containing MathType equations. The equations may not appear correctly in their PDF files, but instead appear to be gibberish.

Reason

MathType equations require fonts to display correctly. If these fonts are not embedded in your PDF files or already present on the recipient's computer, inappropriate fonts will be substituted, resulting in an incorrect appearance. Many users have created PDF in the past without difficulty, so are disappointed when their MathType equations do not appear correctly.

The reason for this difference is simple: when Adobe Reader substitutes a text font for another text font which is not available, the document is still legible because text fonts all have the same characters in the same positions. When a text font is substituted for a symbolic font such as Euclid Symbol or MT Extra which have different characters in those positions, the characters substituted are not simply different representations of the same characters, they are different characters altogether. 

For example, a text font, Times New Roman, is used in the sentence below,

Arial is a dissimilar font, but substituting it for Times New Roman, does not affect legibility. 

Adobe Reader has a sophisticated understanding of text fonts and would substitute a font much closer in appearance to the original, making the substitution unnoticeable. When text fonts are substituted by Adobe Acrobat Reader, most recipients are never aware a font has been substituted.

However, in the following equation, which contains characters from both Times New Roman and Euclid Symbol,

substituting Arial for Euclid Symbol font, yields,

which renders the equation illegible. The equation is not corrupt; the Euclid Symbol font is not available and a text font has been substituted. Many MathType users have distributed many PDF documents without embedding fonts, but because the font substitutions did not affect legibility, they were unaware font substitution was occurring.

Solution

In order to create PDFs that can be correctly viewed on any computer, it is necessary to first take an inventory of the fonts used in your document and configure Acrobat to embed them.

This notice addresses the following subjects:

  1. Making an inventory of the fonts in your document
  2. Configuring Distiller and PDFMaker
  3. Ensuring your font environment is unambiguous
  4. Optimizing or improving the appearance of equations in your PDFs
  5. Improving appearance of equations in your PDF using Convert Equations

Making an inventory of the fonts in your document

MathType users who use MathType's factory settings and are not inserting any special characters, can just embed the MT Extra font. This font is assigned by default to the Styles in MathType upon installation.

The default font used for Greek characters and many other special mathematical symbols is the Symbol font, which you will not need to embed because your recipients will already have it installed.

If you are not familiar with the assignment of fonts to MathType's Styles, please refer to your MathType documentation, accessible through MathType's Help menu. You will need to be familiar with Styles in MathType to fully understand this process.

If you have changed the fonts assigned to the Styles in MathType, or used either the Insert Symbol command in the Edit menu or Other command in the Style menu of MathType to include unusual characters into your documents, you should inventory the fonts in your document. To determine which fonts you need to embed in your document with, do the following:

  1. Launch MathType.
  2. Choose Define from the Style menu of MathType. Select Advanced on the Define Styles dialog.
  3. Make a list of every font which is assigned to at least one style.
  4. If you have used Other command from the Style menu of MathType, add those fonts to your list.
  5. If you have used the Insert Symbol command from MathType's Edit menu to include characters not in MathType's palettes, add those fonts to your list.
  6. If you have characters from other fonts which you have saved in your symbol or macro bars in MathType and have used them in your document, add those fonts to your list. 
  7. Remove the Symbol font from your list if it appears. The Symbol font is included with Windows and Mac OS.
  8. Remove common text fonts such as Times New Roman, Courier, Arial, or other fonts that were included with your word processor or are present in the text of your document. 
  9. Most MathType users will find that they have only MT Extra on their list (unless they are using the Euclid fonts).

Configuring Acrobat to embed MathType's Fonts

Adobe Acrobat comes with a detailed guide in PDF format. It explains how to embed fonts in PDFs. You can access it by choosing User Guide from the Acrobat Start screen or by choosing Acrobat Help from the Help menu of Acrobat.

Nearly all the information relevant to creating PDFs is included in the "Creating PDFs" section of either of these 2 Help files. Reading through this section provides all the information necessary for configuration, but we provide references to important sections here for the benefit of our customers who require quick answers. At some point, however, we recommend reading the parts of the Acrobat Guide which are relevant to the process you use to create PDFs so that you can get the most out of Acrobat and its many features.

To learn how to embed fonts in PDFs, read the articles PDF fonts and Adobe PDF conversion settings (especially the section "Customize Adobe PDF settings").

If you are having problems embedding fonts in your PDF documents, please contact Adobe's Technical Support.

Ensuring your font environment is unambiguous

Problems result when both the PostScript and TrueType versions of the same font are installed. OpenType fonts in Windows and macOS should be considered equivalent to TrueType fonts. Bitmap fonts should not cause problems. When an application needs to use a font, if two different versions of the same font are installed, the one that should be used by an application is ambiguous.

If you are experiencing problems creating PDFs, you should open your Fonts Control Panel (Windows) or Font Book app (Macintosh), making sure you don't have both the TrueType and PostScript versions installed of any fonts that you are using in your equations. Please note that many application installers and updaters will install fonts on your system, so you may not know they were installed. If you have two versions of the same font installed, you should move one of the versions out of your fonts folder (or use Font Book to disable it, if you're on a Mac). It is necessary to reopen and resave your MathType equations and then the document containing them, before successfully creating a PDF free of ambiguous font references.

Optimizing or improving the appearance of equations in your PDFs

When working with Microsoft Word documents with MathType equations (or most any document other than EPS or PS), you should be able to get excellent results by using the Adobe Acrobat printer driver, accessible through the Print dialog. In the Print dialog, click Properties, and make sure the PDF Settings include the embedded fonts from your list above.

Adobe recommends using Distiller, rather than PDFMaker, for best results when working with PostScript (.ps) or Encapsulated PostScript (.eps) files. PDFMaker will usually provide good results, but some users with large, complex mathematical expressions may experience formatting problems in the equations in their PDFs other than simple font substitution. Using Distiller rather than PDFMaker can correct many such problems.

Adobe created the PostScript printer language which is the underlying technology in PostScript (Type 1) fonts, PostScript printers, EPS (Encapsulated PostScript) files, Distiller, and Acrobat. By using PostScript technology exclusively, more consistent results can be achieved. To use PostScript fonts with MathType to create PDFs, deactivate the TrueType versions of MathType's fonts and activate the PostScript versions as described in the previous section. You must either activate the PostScript fonts before creating your equations, or update your equations afterward. MathType will default to the TrueType versions of its fonts if both versions are available.

Please note that Design Science does not distribute the PostScript version of the Symbol font with MathType. If you would like to use PostScript fonts, you must either have the PostScript version of the Symbol font or use the PostScript version of Euclid Symbol.

Improving appearance of equations in your PDF using Convert Equations

In some cases, the embedded MathType equation metafiles just need to be refreshed to help improve the PDF creation process. Before converting the Word document to Adobe's PDF format, do the following:

  1. Open the document in Word and choose the Convert Equations command from the MathType tab or menu.
  2. Select 'Whole Document' under Range and 'MathType equations (OLE objects)' under Convert Equations To.
  3. Click OK to begin the conversion process.
  4. Once finished, try the PDF creation process again to see if the results have improved.

Top of page

TechNotes Home   |   TechNote Wizard   |   Contact us

Copyright © 1996-2018 Design Science. All rights reserved.
Privacy statement
Follow MathType: