Skip NavigationDesign Science: How Science Communicates
Products Solutions Store Support Reference Company View Cart
 
 
TechNote #100: Last modified: 07/01/04

Resolving Issues Using the MathType 3.x Commands for Microsoft Word for Macintosh


The information in this document applies to:

MathType 3.7 (Mac)
MathType 3.6 (Mac)
 

Microsoft Word 2001 (Mac)
Microsoft Word 98 (Mac)
Adobe Type Reunion
Extensis Suitcase


Issue

Users may experience one or more of the following problems getting MathType to work correctly with Microsoft Word: 

  • Type 2 or 3 error messages when launching Microsoft Word
  • The MathType toolbar button and additional options in Tools menu may be missing
  • Error messages when trying to insert or edit MathType equations
  • Crashes or freezes when using MathType within Microsoft Word
  • We have a number of other notices that address specific problems that you may experience when using MathType with Microsoft Word. Before following the steps outlined in this TechNote, please consider if one of the notices below addresses your problem specifically:

    96. Using MathType 3.x with Macintosh OS X

    74. Equations Are Displayed as Empty Boxes in Microsoft Word 

    73. Equations Are Displayed as { EMBED.Equation } in Microsoft Word

    64. "The Disk is Full or Too Many Files Are Open" Error Message in Microsoft Word


    Reason

    The MathType Commands for Word rely on Visual Basic for Applications (VBA), a Microsoft Office component, to function correctly. If VBA is not working correctly, you may experience the above problems when you try to use the features provided by the MathType Commands for Word.


    Solution

    We have basic regimen of procedures that reliably corrects problems using the MathType Commands for Microsoft Word by eliminating problems with VBA.

    1. Type 2 or 3 error messages when launching Microsoft Word

    2. MathType toolbar button and extra commands in Tools menu missing

    3. "Server application or source file cannot be found" error message

    4. Other Error Messages


    Type 2 or 3 error messages when launching Microsoft Word

    This error can usually be corrected quickly by resetting VBA. If you can launch Word without receiving errors, but receive a Type 2 or Type 3 when you try to insert a MathType equation, it may be caused if you are using Adobe Type Reunion (ATR) or Extensis Suitcase. Adobe Type Manager (ATM) does not cause any problems. Please contact Technical Support if you are using Adobe Type Reunion or Extensis Suitcase.

    1. Locate your Word Startup folder.
    2. The default location of the Startup folder is,

      Microsoft Office [version]:Office:Startup:Word

    3. Open Word's Startup folder.
    4. Drag MathType Commands for Word to the desktop.
    5. In Word, choose Tools>Macro>Visual Basic Editor. The Visual Basic Editor will open.
    6. Choose Run>Reset. Nothing will appear to happen, but VBA has been reset.
    7. Choose File>Close and Return to Microsoft Word.
    8. Quit Word.
    9. Place MathType Commands for Word back in your Word Startup folder.

    You should no longer get a Type 2 or 3 error when running Microsoft Word.


    MathType toolbar button and extra commands in Tools menu missing

    If your MathType commands and toolbar button are absent, before trying the steps below, ensure that the Word 5.1 Menus option is not checked under the View menu of Microsoft Word. When this option is checked, all menu and toolbar customizations are suppressed. If this option was not checked, follow the instructions in the last section of this notice, then reinstall MathType.


    "Server application or source file cannot be found" error message

    This error is a result of MathType not being properly registered in Microsoft's Object Linking and Embedding (OLE) registry. To correct it, you should rebuild your Desktop and force Microsoft Office to create a fresh copy of your OLE registry.

    Apple recommends rebuilding your desktop once a month. To rebuild your desktop,

    1. Restart your Mac and hold down the Command and Option keys until you get a dialogue asking you if you want to rebuild your desktop.
    2. Click "Yes".
    3. Your desktop will rebuild itself.

    Symptoms of a desktop that needs to be rebuilt are icons that revert back to generic icons, or which do not do anything when they are double-clicked. Rebuilding your desktop will solve many problems and is always a first good line of defense if you are having any problem with your Mac and have not rebuilt your Desktop recently.

    Deleting the following files will force Microsoft Word to create a fresh OLE registry. Rebuild your Desktop first to ensure they are recreated based on updated, accurate file location information.

    1. From the Preferences folder in your System Folder, delete:

      Embedding Preferences
      PPC Registration Database
      Registration Database
      VBA Preferences

    2. Some users will not have both PPC Registration Database and Registration Database. Delete both if they exist.
    3. If you are using Office 2001, from the Microsoft folder in your Preferences folder, delete:

      Office Registration Cache 2001
      Word Settings (9)

    4. If you are using Office 98, from the Preferences folder in your System Folder, you should also delete:

      Office Registration Cache
      Word Settings (8)

    5. From the Extensions folder in your System Folder, delete:

      Microsoft Component Library
      Microsoft OLE Automation
      Microsoft OLE Library
      Microsoft Structured Storage

    6. Launch Word again. Word will take much longer than usual to load, as the deleted files are recreated by a "First Run".
    7. After Word has finished launching, quit it.
    8. To manually register MathType in Microsoft Word's OLE registry, hold down both the Option and Command keys while double-clicking on the MathType icon (not the toolbar button in Word), as if you were going to launch MathType by itself.
    9. You will hear a system beep and the MathType startup screen may flash on your screen, but MathType will not launch.
    10. MathType has reentered itself in your OLE registry.

    You should no longer receive the "Server application or source file cannot be found" error message.


    Other issues using the MathType Commands for Microsoft Word

    If you are receiving error messages or the commands and toolbar button are missing, you should rebuild your desktop, delete your Word Normal template, fully update Office, and reinstall MathType. This is usually sufficient to fix any other problems not specifically addressed above.

    Apple recommends rebuilding your desktop once a month. To rebuild your desktop,

    1. Restart your Mac and hold down the Command and Option keys until you get a dialogue asking you if you want to rebuild your desktop.
    2. Click "Yes".
    3. Your desktop will rebuild itself.

    Symptoms of a desktop that needs to be rebuilt are icons that revert back to generic icons, or which do not do anything when they are double-clicked. Rebuilding your desktop will solve many problems and is always a first good line of defense if you are having any kind of problem with your Mac and have not done so recently.

    Your Word Normal template contains any macros, styles, or menu and toolbar customizations that you have defined. If you rename or delete it, Microsoft Word will create a fresh one and Microsoft Word will be reset to its defaults.

    Unless you have defined styles or autotext entries, written or recorded macros, or made toolbar customizations that you want to save, you should delete Normal template. You will need to redo any menu customizations. If you prefer to save customizations that you have made, rename your Normal template to Normal.bak and use the Organizer to transfer styles, autotext, macros, and custom toolbars to your new Normal template. Word's help files explain how to use the Organizer.

    1. Quit Microsoft Word and open your hard drive and open,

      Microsoft Office [version]:Templates

    2. Inside, you should find a file called Normal that has a Microsoft Word document icon.
    3. Delete it or rename it Old Normal.
    4. Launch Microsoft Word. Word will take a little longer than normal to start up but will automatically create a new Normal template in your Templates folder.

    Updates for Microsoft Office 2001 are available at http://www.microsoft.com/mac/download/default.asp#Office2001.

    Updates for Microsoft Office 98 are at http://www.microsoft.com/mac/download/default.asp#Office98.

    Note: As noted in the MathType 3.6 and 3.7 Read Me files, you must install the Combined Updater for Word 98 for the MathType Commands to work with Word 98 due to a bug in the version of Visual Basic for Applications that was originally released.

    To reinstall MathType, you can either use your MathType CD-ROM, if you had MathType shipped to you, or download a copy of the MathType 3.7 installer from our download page. MathType 3.6 users can upgrade to MathType 3.7 at no charge if they request a free upgrade from our Sales department including their MathType 3.6 registration number.

    After doing all of the above, you should be able to use the MathType Commands for Microsoft Word without difficulty.


    Top of page

    TechNotes Home   |   TechNote Wizard   |   Contact us

    Copyright © 1996-2018 Design Science. All rights reserved.
    Privacy statement
    Follow MathType: