Skip NavigationDesign Science: How Science Communicates
Products Solutions Store Support Reference Company View Cart
 
 
TechNote #:85 Last modified: 01/21/05

Converting Documents between Applications


The information in this document applies to:

MathType 6.x (Win)
MathType 6.x (Mac)
MathType 5.x (Win & Mac)
MathType 4.0 (Win)
MathType 3.7 (Mac)
MathType 3.6 (Mac)
MathType 3.5 (Mac & Win)

AppleWorks (Mac & Win)
Microsoft Word (Mac & Win)
PageMaker (Mac & Win)
QuarkXPress (Mac & Win)
WordPerfect (Mac & Win)

 

Issue

Many people try to open a document containing MathType equations with another application and find that their equations no longer appear correctly or are omitted entirely. If you are transferring a document between contemporary versions of the same application on the Windows and Macintosh platform, you should read our notice about Transferring Documents between Windows and Mac OS. If you are transferring between different applications and platforms, you should read both notices. 


Reason

Different applications use different file formats which are not always handled correctly by translators. 

Note: References to "different applications" in this notice should be understood to include different versions of the same application. Some versions of applications, such as Word 97, 2000, and 2002 (XP) on the Windows platform are completely intercompatible, but this is atypical. Check the documentation for the most recent version of your application to learn more about compatibility with earlier versions.

Opening a document with a different application subjects the document to conversion and something is often lost in translation, whether formatting, embedded graphics, or both. Conversions are rarely perfect. You should always avoid converting documents when possible. When you use a "Save As" feature to save a document in a format other than the application's native format, you are translating it.

MathType is not involved in document translations. Success is determined entirely by the sophistication of the translator in the program converting the document.


Solution

This article addresses the following basic topics,

1. Choosing among available converters

2. Manually cutting-and-pasting between two open applications

3. Exporting equations from Word for Windows 97, 2000, 2002, 2003 and 2007 with MathType and manually reinserting them

4. Saving equations as individual files and manually reinserting them

and the following common conversions,

5. Converting Microsoft Word for Windows documents to QuarkXPress for Windows

6. Converting Microsoft Word for Windows documents to QuarkXPress for Macintosh with MathType

7. Converting Microsoft Word for Windows documents to QuarkXPress for Macintosh with MathType

8. Converting Microsoft Word for Windows documents to PageMaker for Macintosh

9. Converting Microsoft Word for Macintosh documents to PageMaker for Macintosh


Choosing among available converters

You cannot convert a document containing equations to a format that does not support embedded graphics. The converter will simply discard the graphics. Make sure that the program you are trying to open the document in supports embedded graphics.

Programs use a different translator for each document format that they can import or export ("Save As"). Try saving the original document in different formats if saving it in the native format yields poor results. 

Rich Text Format (RTF) is often a good format to save documents in to transfer them between programs if both programs support the format. 

Saving a document as HTML will not work. The equations will lose their vertical positioning and be converted to GIFs which cannot be edited by MathType.

Every translator included with an application may not be installed in the standard installation. If you do not find a translator for the specific type of document that you are opening, check if there are other translators included with your software and install them. 

Sometimes, an effective converter is not available. You then have two options: 

You can run both applications simultaneously and copy each equation from the original document to the clipboard and then paste it into the receiving document. Or, you can save the equations as individual graphics files via MathType and embed them manually in the receiving application after translating the text portion of the document. Both methods are outlined below. 


Manually cutting-and-pasting between two open applications

You need to have both programs installed on your computer to use this method.

After converting the text portion of the document, delete equations which did not convert correctly. With both the original document open in the authoring application and the target application open with the converted text portion of the document, single-click on each equation in the original document, copy it to the clipboard, switch to the receiving application, move the cursor to the analogous place in the document where the equation belongs, and paste it in.


Exporting equations from Word for Windows 97, 2000, 2002, 2003 and 2007 with MathType

MathType 5's add-in for Microsoft Word adds an "Export Equations…" to the MathType menu of Microsoft Word. This command will export all the equations in a Microsoft Word document to a designated folder, saving them as GIFs, WMFs, or one of MathType's supported EPS file formats. The Export Equations command lets you either leave the original equations in your Word document intact or replace them with the filename assigned to each exported equation. MathType 5 users should refer to "Tutorial 18: Exporting Equations in Microsoft Word" for more information about using this feature.


Saving equations as individual files and manually reinserting them in MathType

Make sure that you have read the section titled "Working with Equation Files" in Chapter 5 of your MathType User manual.

You should first convert the text portion of the document. It may be necessary to create a copy of the document, delete all the equations from it, and import the text portion of your document into your target application. Correct any formatting problems in the text resulting from conversion.

Go through the original document, double-click on each equation, and choose the Save As option in the File menu of MathType to save the equation as a WMF (Win), PICT (Mac), GIF, or EPS file. After saving the equations as separate files, you will need to insert them individually into the translated text portion of your document.


Converting Microsoft Word for Windows documents to QuarkXPress for Windows

Quark recommends embedding graphics into QuarkXPress as EPS files with TIFF screen graphics, rather than Windows Metafile Format graphics (WMFs). Microsoft Word users will typically insert equations via Object Linking and Embedding (OLE) which embeds the equations in the document as WMFs. 

To translate the Word for Windows document into QuarkXPress, you should first export (MathType 5) or save (MathType 4 or earlier) the equations in your Word document as individual EPS files with TIFF screen graphics.

If you are using MathType 5, in the Export Equations dialog, check the box that says "Replace equation with file name" to remove the WMFs from the Word document.

Users of MathType 4 and earlier should manually delete the equations. Import the text from the Word document into QuarkXPress and then create picture boxes for the equations and place them back into QuarkXPress.

Translating by separating graphics from text and then recombining them is fairly time-consuming, but provides the best results. Since QuarkXPress supports OLE and Windows Metafile Format graphics, many users would prefer to simply save the document in Rich Text Format (RTF)

To convert the equations into EPS files with attached TIFF screen graphic in MathType 4 or earlier, do the following:

  1. Open a copy of your original Microsoft Word for Windows document in Microsoft Word.
  2. Double-clicking on each equation to open it in MathType.
  3. Choose File and then Save As.
  4. For "Save as type", select "Encapsulated PostScript/TIFF (.eps)".
  5. MathType allows you to define a numbering format for equations. Numbering your EPS files will make their later manual placement easier. For information about numbering files, please see "Automatically Numbering Files" in Chapter 5 of your MathType User Manual.
  6. You should delete each equation and replace it with its file name, i.e., "Eqn001.eps", etc. to make later insertion simpler.
  7. After you have converted all the equations in your Word document to individual EPS files, save your document either as a regular document file or as "Rich Text Format (*.rtf)". 
  8. After creating a Text box in your target QuarkXPress document, import the text portion of your Word document by using the Get Text command in the File menu of QuarkXPress. You will need to manually correct any formatting lost in translation.
  9. Create a picture box for each individual equation and place the corresponding EPS file in it. 
  10. You will need to baseline in-line equations manually.

MathType 5 users should see "Tutorial 18: Exporting Equations in Microsoft Word" in Chapter 4 of the MathType 5 User's Manual.


Converting Microsoft Word for Windows documents to QuarkXPress for the Macintosh with MathType

Converting Word for Windows documents to QuarkXPress for Macintosh publications is a very common translation. 

Most QuarkXPress users prefer EPS files with attached screen graphics to PICTs or GIFs. WMFs are not supported on the Macintosh and graphic converters only rarely handle them correctly due to their complexity. Unfortunately, converting a Word document into a QuarkXPress document with linked EPS files is a very complicated translation and requires a lot of manual operations. QuarkXPress users who do not mind using PICTs instead of EPS files with screen graphics may use the same method used to convert Microsoft Word for Windows documents to PageMaker for Macintosh, which is the simplest, if you have all the necessary software.

MathType 5 users who prefer EPS files should do the following, but must be using identical sets of PostScript fonts (MT Extra, Symbol, and the font used for Text, Functions, and Variables) for their equations on both platforms, otherwise, the method for MathType 4 and earlier that separates graphics from text on the Mac side should be used.

  1. Export the equations from Word, choosing to save them as EPS w/TIFF screen graphics, replacing the equations with their file names.

  2. Save your Microsoft Word document either as a regular document file (.doc) or as "Rich Text Format (.rtf)".
  3. Transfer your EPS files and saved Word document to your Macintosh.
  4. After creating a Text box in your target QuarkXPress document, import the text portion of your Word document by using the Get Text command in the File menu of QuarkXPress. You may find that opening your document in Microsoft Word for Mac and saving it, either in a contemporary or older Word document format before importing it into QuarkXPress improves your results.
  5. Manually correct any text formatting lost during translation.
  6. Find each file name, create a picture box for its corresponding equation, and place the corresponding EPS file in it.

Converting Microsoft Word for Windows documents to QuarkXPress for Macintosh with MathType

The Word document should be separated into a formatted text file and equations saved as individual equation graphic files. Two paths are available: separating the Word document on the Windows platform or separating it on the Mac platform.

If you have a copies of Microsoft Word and MathType for Macintosh, you should separate the text and graphics in the Word document on a Macintosh using the method below,

  1. Open a copy of your original Microsoft Word for Windows document in Microsoft Word for Macintosh. Word for Mac will attempt to convert the equations from WMF files to PICTs, with only partial success. The equations need to be updated using MathType for the Macintosh.
  2. Open MathType for the Macintosh and make sure that the currently selected Preferences are the ones you want used for your equations.
  3. From the Tools menu of Microsoft Word, choose Update Equations.
  4. For Range, make sure "Whole document" is selected and click "Update" to update all the equations in the document. If some of the equations appear with characters replaced by ? or templates replaced by [unknown template], please see our notice about cross-platform conversions.
  5. Double-click on each equation to open it in MathType.
  6. Choose File and then Save As.
  7. For "File Format", select "PostScript (EPS) w/PICT graphic".
  8. MathType allows you to define a numbering format for equations. Numbering your EPS files will make their later manual placement easier. For information about numbering files, please see "Automatically Numbering Files" in Chapter 5 of your MathType User Manual.
  9. You should delete each equation and replace it with its file name, i.e., "Eqn001.eps", etc. to make later insertion simpler.
  10. After you have converted all the equations in your Word document to individual EPS files, save your document either as a regular document file or as "Rich Text Format (*.rtf)". 
  11. After creating a Text box in your target QuarkXPress document, import the text portion of your Word document by using the Get Text command in the File menu of QuarkXPress. You will need to manually correct any formatting lost in translation.
  12. Create a picture box for each individual equation and place the corresponding EPS file in it.

If you do not have MathType 3.5 or 5 for Windows, or MathType 3.7 and Microsoft Word for Macintosh, you should either purchase MathType 5 for Windows or MathType 3.7 for Macintosh. Due to a bug in MathType 4.x for Windows, we do not recommend using MathType 4 to create EPS files. If you own MathType 4, you can contact technical support if you would like a free copy of MathType 3.5 to create EPS files on Windows. Make sure to include your registration number.

  1. Open a copy of your Microsoft Word document in Microsoft Word for Windows.
  2. Make sure that your are using MathType's PostScript fonts and that the TrueType versions are inactive. The equations in your document should not use the Euclid family of fonts or the MT Symbol font, which have not been released for the Mac. You should use the MT Extra and Symbol fonts instead, which are available on the Mac.
  3. Double-click on each equation to open it in MathType.
  4. Choose File and then Save As.
  5. For "Save as type", select "Encapsulated PostScript/TIFF (.eps)".
  6. MathType allows you to define a numbering format for equations. Numbering your EPS files will make their later manual placement easier. For information about numbering files, please see "Automatically Numbering Files" in Chapter 5 of your MathType User Manual.
  7. You should delete each equation and replace it with its file name, i.e., Eqn001.eps, etc. to make later insertion simpler.
  8. After you have converted all the equations in your Word document to individual EPS files, save your document as "Rich Text Format (*.rtf)".
  9. Transfer the EPS files and the RTF version of your Word document to your Macintosh.
  10. After creating a Text box in your target QuarkXPress document, import the text portion of your Word document by using the Get Text command in the File menu of QuarkXPress. You will need to manually correct any formatting lost in translation.
  11. Create a picture box for each individual equation and place the corresponding EPS file in it. 

Converting Microsoft Word for Windows documents to PageMaker for Macintosh

By converting the document to a Microsoft Word for Macintosh document, you can use the conversion method outlined below for converting Microsoft Word for Macintosh documents to PageMaker for Macintosh. MathType and Microsoft Word for Macintosh are necessary to use this method. This method results in a PageMaker document containing embedded PICTs.

  1. Open the Microsoft Word for Windows document in Microsoft Word for Macintosh. The majority of the equations will probably not appear correctly because they have been converted to PICTs by the translator for WMFs in Microsoft Word for Macintosh, which does not handle equations very well.
  2. Make sure that your Style definitions in MathType are correct for your publication.
  3. Choose Update Equations from the Tools menu of Microsoft Word.
  4. For Range, make sure "Whole document" is selected and click "Update" to update all the equations in the document.
  5. In Microsoft Word, from the Tools menu choose Update Equations. The equations in your document will be recreated by MathType and should appear correctly when the process has finished.
  6. Manually correct any formatting problems in Microsoft Word for Macintosh.
  7. Follow the instructions below for converting a Microsoft Word for Macintosh document to PageMaker for Macintosh.

Converting Microsoft Word for Macintosh documents to PageMaker for Macintosh

Many users have reported good results by simply saving a Microsoft Word for Macintosh document in the Microsoft Word 5.1 format and importing it into PageMaker.

  1. Open the Microsoft Word for Macintosh document.
  2. From the File menu, choose Save As. 
  3. Under Save File as Type, select Microsoft Word 5.1 for Macintosh. You should give your Microsoft Word 5.1 for Macintosh version of this file a different name, rather than replacing the original.
  4. Quit Microsoft Word and open PageMaker.
  5. From the File menu of PageMaker, choose Place. The Place Document dialog will open.
  6. Select the Word 5.1 version of your document and click OK.

Top of page

TechNotes Home   |   TechNote Wizard   |   Contact us

Copyright © 1996-2018 Design Science. All rights reserved.
Privacy statement
Follow MathType: